Posts by Delpierooo

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi,

I have the same issue.

PrimaThemes can you tell us which line of code it was? It might be the same issue for me. What would be the best way to investigate which theme code could be causing this?

Thanks in advance!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hello!

Question: If I buy an extended license for some Worpdress theme, will that theme still stay on Themeforest market ot will it get removed?

THANKS!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi.

I want to start developing Wordpress themes for Themeforest and I am wondering if I can use PSD templates that are for sale on Themeforest. What are the conditions for doing this? Extendend licence, author agreemen, ...?

TNX!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Ok, i share the code, i’m hoping someone with better php skills would check it :) http://www.lifeofstrange.com/bbpress-register.zip

Can this zip still/again be provided for download? :)

TNX!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi,

if I use php to check the purchase code all goes ok. But I am testing this before submiting a form(bbpress: form.user-register)

<form … onsubmit=”return checkPurchaseCode()”.. >

So I have a js function called before submiting.

If I change action so some custom file (checkPurchase.php), I can(successful) check the purchase code there using php, but don’t know how to get back to submit the form (bbpress: form.user-register)

Any idea about this maybe?

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi again.

This is how it would look like:

http://jsfiddle.net/SQGqp/

tnx.

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

This is what I get in the Console:

XMLHttpRequest cannot load http://marketplace.envato.com/api/edge/XXXXXXX/YYYYYYY/verify-purchase:550e8400-e29b-41d4-a716-446655440000.json. Request header field X-Requested-With is not allowed by Access-Control-Allow-Headers.

Any idea?

P.S. I am using the right username and api key, just didn’t insert it here on the forum.

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi,

yes I am using the right username and api. If I open the js in a browser the json file is displayed ok. And if are put that content in a local file(was trying this on my localhost) it works ok. It seems that something is missing if using a JSON file from other server. Read something about that, but none solution worked. Any idea for the fix?

TNX!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi.

I am trying to verify the purchase code of an item using: http://marketplace.envato.com/api/edge/USERNAME/API-KEY/verify-purchase:550e8400-e29b-41d4-a716-446655440000.json

In the javascript code I am using:

var url='http://marketplace.envato.com/api/edge/USERNAME/API-KEY/verify-purchase:550e8400-e29b-41d4-a716-446655440000.json';

$.getJSON(url, function(jd) {     
 var entire_purchase = jd["verify-purchase"];     
 var buyer_name = entire_purchase.buyer;         
 alert(buyer_name);
 });

I have the api key and username inserted but still can’t get it to work. So somewhere taht adding ?callback=? in the end of the url would help but it doesn’t.

Any idea what I am doing wrong? The code itself work ok if I have the json file localy for example, but need to read that one.

TNX!

35 posts
  • Has been part of the Envato Community for over 4 years
Delpierooo says

Hi,

that simply isn’t going ok, since I dont have the item or am missing something.

Menu filter:

add_filter( 'wp_nav_menu_items', 'custom_menu_function', 10, 2 );

Then the filter functions starts like this:

 function custom_menu_function ( $items, $args ) {

 $dom = new DOMDocument();
        $dom->loadHTML($items);
        $linkNodes = $dom->getElementsByTagName('a');
        $classes= $dom->getElementsByTagName('li');
        $count = $linkNodes->length;

        for($i = 0;$i < $count;$i++)
        {

How to get the page id's here for each menu item, not the id that the menu item has.
  }
}  

So if I have created page Test that has id=2 and I have tbhis item in the menu. How to get it’s id(2) in the menu filter above?

Am I missing some basic thing?

Tnx.

by
by
by
by
by
by