Posts by UXbarn

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

Thanks @Matthew! Can’t wait to read your article! :)

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

Not good. :(

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

I use a modified version of the importer plugin and changed the class name so it doesn’t conflict. You can also make it look almost exactly like the demo by using use add_option() in the importer to import data into your options panel such as social icons, fonts, colours, settings and other things that the importer wouldn’t usually do.

You can also use set_theme_mod() in the importer so it also sets the menu location, something the default importer doesn’t do.

I might post an example if you guys are interested.

EDIT: Also 1Click demo installers can drastically cut down your support tickets. It is definitely something to look into.

+1 too. Really interested. :)

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

Low sales + so quiet today.

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

So, is this the reason why I still haven’t got my money today? :D

Anyway, is it true seriously?

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

I’m waiting too. :|

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

What!? With no safety? This is cool but too much crazy! :O

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

Thank you @Eric, @TommusRhodus.

PHP version sounds make sense for my case. One of my buyers tried it on different hostings and the issue did not happen on another except the first server. Anyway I did not check the PHP version but it should be a major factor among the different servers/hostings.

Do you know how can PHP version has something to do with the customizer, I mean something under the hood? Just curious about it.

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

I am using option type for the settings.

When I tried debugging the code, “get_option()” returned me the values correctly in the customizer’s live preview screen. I saved it. But when I went to the frontend, the function just returned “false” as it did not exist. I went to the customizer again, all those saved changes were gone somehow like it never happened. :S

384 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

Hi everyone,

I have implemented WP Theme Customizer into my themes and in most of the cases, it works without problems.

But I have got a strange issue from only a few buyers. They changed some options using the customizer and saved but the changes have never been updated in the frontend. When going back to the customizer screen, all changes reverted back just like nothing happened.

I tried to check the browser console, debug the code but no luck. There are no error messages, nothing. Really, I could not find what is the cause on this strange issue.

It never happened on my end so I also have no idea why.

Have you ever experienced the same case like mine? Any idea on the issue?

Thank you.

by
by
by
by
by
by