Posts by lifwanian

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Thank you for the reply… I am sure that I am using the laco tween… Its for the intro, to make the pictures burn from one to another.

If I were to only have the intro, and delete the include “contactPageForm.as”, or wise versa, everything works great, but the problem appears when I have them both up together.

The error message appears however from a file called mc_tween2.as, which is used within the contactPageForm.as file. I bought the contact form from this website, and so it was not me who decided to include those two .as files.

Here is how it looks in the mc_tween2.as file :

.... default: trace (“MC TWEEN ### Error on transition: there’s no \”“_animType”\” animation type.”); return 0; }

I just dont see how they would conflict with one another…

Thanks for the reply again!

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Hello. I have two problems that I have run into on a website, and have no idea what to do…

I have a slide show in the beginning that starts up and uses and external .as file, and everything works fine until I press the contact us page, which uses another external .as file. When I click on the contact us page, I get an error that says :

MC TWEEN ### Error on transition: there’s no “easeInOut” animation type.

and then the intro slide show no longer works after that. Here is the code I have for the intro slide show:

include “lmc_tween.as”

mc.brightOffsetTo(-100,0); mc.brightOffsetTo(0,2,”easeInOut”,0,startSlide()); function startSlide() { // starts the effect mc.brightOffsetTo(-100,1,”easeInOut”,3,backBright); } function backBright() { if (mc._currentframe<mc._totalframes) { // goto next frame i.e. next image mc.nextFrame(); // then bring brightness to ‘0’ mc.brightOffsetTo(0,2,”easeInOut”,0,startSlide()); } else { // goto first frame mc.gotoAndStop(1); // and set brightness to ‘0’ mc.brightOffsetTo(0,2,”easeInOut”,startSlide()); } }

And then for the buttons I have :

sticker = “home”

function homeClicked() { if (sticker != “home”) { _root.mcLoader.unloadClip(myLoader); _root.mc._visible = true; mc.brightOffsetTo(-100,0); mc.gotoAndStop(1); mc.brightOffsetTo(0,2,”easeInOut”,startSlide()); sticker = “home”; } } function contactClicked() { if (sticker != “contact”) { _root.mc._visible = false; removeMovieClip(_root.mc); _root.mcLoader.loadClip(“contact.swf”,myLoader); sticker = “contact”; } }

The other problem that im having is whenever I press another button in the menu, and then go back to the intro home, the slide show timing gets screwed up and it goes much faster than its supposed to.

Any help would be greatly appreciated. Im loosing my hair here trying to figure it out..

Thanks, Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

sweet! Thanks alot. I also had a mistake in my own function, which screwed it all up as well. Thanks for all the help!

Merry Christmas!

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

I’ve tried that. Still doesn’t work. Thanks for trying though :)

Any other ideas?

Thanks, Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Hey guys, is there a way that I could call a function through another file’s code? I have the main file, and within it is a loader which calls another swf file. What im trying to do is when the user clicks on the sound button, the function from the main file would be called. I would just turn the sound off, but the function has many different things that happen, so I really need to call the function instead.

Thanks, Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Hey guys. Is there a way to make the sound on a website turn off when a link is clicked and another window is opened. Then when the user goes back to the regular page, the sound goes back on…

I have a site where the music is playing, but I have a button which brings up a slideshow movie on a different page. The movie also has different music playing, but I dont want them to interfere…

Thanks, Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

I have in the main scene of the site where the intro swf file is loaded, through a loader component. I was wondering if there is a way to preload the intro swf file in the preload scene of the main file. So like when you go to the site, and everything loads, if the intro swf file could be loaded too.

In the main scene of the main file, I have the following :

_root.mcLoader.loadClip(“home.swf”,myLoader);

Thanks for all the help, Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Hey guys, I created an xml gallery, and everything works great. But if I call the swf file from my main site file, the pictures begin to overlap, and become off centered. I know this isnt much to list, but theres so much that I was just wondering if anyone knows where to begin….

THanks! Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

hey guys. I created an XML gallery for my site, and I was wondering if you could help me out with it. I have everything working fine, if its for a single gallery. Now I want to make it categorized. So if someone presses on the first category, it will go to the frame, and on that frame it would load the pictures needed.

I have it working to a point. ex. category 1 – 3 pictures category 2 – 4 pictures.

Actionscript on each category frame just includes the “include(“category…. .xml”);

If I press on category 1, it will load the 3 pictures fine. If I press on category 2, it also loads fine. But if I press on category 1 again, it loads the 3 new ones, which is good (replaces the first 3), but keeps the 4th pic from category 2…

I was wondering, if there is a way to clear the loaded pictures everytime a category button is pressed.

Thanks for the help! Justin

1093 posts
  • Has been a member for 7-8 years
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Won a Competition
  • Envato Studio (Microlancer) Beta Tester
  • United States
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
lifwanian says

Hey guys. Im trying to place some items at the very corners of my site, and Im having a bit of trouble.

Before, I used stage.align = “TL”;

and having something like

icon_mc.onEnterFrame = function() { this._x = stage.width – 50; this._y = stage.height – 50; }

This worked before. But now for new site, I need to have stage.align = “C”; and now the onEnterFrame seems to work very weird. Doesnt work anymore. I tried to create a listener way, but that didnt seem to work either.

Any ideas?

Thanks.. Justin

by
by
by
by
by
by