Posts by mattmatt88

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

In my woocommerce product, I have attributes with many values.

For example if I would have these values for an attribute:
Water | Air | Fire
It would automatically order the values alphabetically to:
Air | Fire | Water

How can I change it so that the content of the attributes aren’t reordered automatically?

Thank you

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

THANKS a lot!

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

I see what order do I need for wordpress?

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

</IfModule>

# END WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
</IfModule>

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

but it only works for the home page.

for example not for www.mypage.com/PAGE1

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

@Gareth: That’s not what I need. I always want to redirect to a non-www address, doesn’t matter on which page I am.

@sevenspark: I have no experience with that

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

Hi I have the following code in my htaccess but it only redirects the main page to non-www.

If I type www.mypage.com/pageX there is no redirection.

What can I do to always redirect?

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

Thank you, I think I want to have the WPML solution.

A SEO question:

I use the WPML-function “Add links to the original content with rel=”canonical” attributes.”

But is it very bad for SEO if I have mysite.us and mysite.co.uk

with, more or less, the same content?

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

Hello,

I’m not sure what’s the best solution for my needs.

I have an english .co.uk domain with thousands of blog posts and now I want to create an american .us page, that is pretty the same page BUT not every blog post should also appear on the american page and they also shouldn’t have the same date.

I’m not sure if I should use WP Multisite or WPML, and which plugin I should use additionally.

Both create subdomains, so mypage.co.uk -> subdomain.mypage.co.uk. So, I also would need an additional plugin? Can I use MU Domain Mapping (http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/) with WPML? So that subdomain.mypage.co.uk would be reachable under mypage.us? Is this ok for SEO?

If that works, I think I would prefer WPML because it’s easy to create duplicates of the blog posts.

What do you think?

Thank you

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

I don’t have access to the sql on this site and I’m not really familiar with it.

But do you have an idea, why the themes and everything else are found, but not the plugins of the wordpress installation? The plugin page is empty. If I install a new one, it’s installed in the right (plugins) folder. But it’s not in the list and it doen’t work.

If I’m trying to activate it after the intallation in the wordpress admin menu it says “The plugin does not have a valid header”. (But I don’t intall it like plugin/akismet/akismet)

I have changed my Domain. I think the problem is since that

80 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
mattmatt88 says

Hello,

I need fast help and the wordpress forum isn’t very fast in my opinion and you guys are always great ;)

I have a blog like www.mypage.com

but in the general settings the Wordpress URL is http://www.mypage.com/mypage which is wrong. The blog URL is correct.

When I change it to http://www.mypage.com, it doesn’t work. It is automatically changed back.

It would be ok, if the URL is “http://www.mypage.com/mypage”. Everything works BUT the plugins I’ve installed are not in the list.

Do you have an ideas what’s wrong?

by
by
by
by
by
by