28 posts
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Referred between 10 and 49 users
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
  • United Kingdom
ClientEngage says




One issue I have run into quite a few times is that the license/purchase-box on item pages does not show up. Instead, the loading indicator shows-up indefinitely.
That’s not specifically related to the visual refresh but we’re definitely looking into this.

Cheers Justin,

Just checking whether anybody has taken a look? It happens quite often and, seeing it’s the purchase button, this is quite important to conversion – I’d imagine. :-) ... It happens on other pages, too, and affects the hover-previews.

Uncaught ReferenceError: $ is not defined main-a1a1386643f7018a89c3bd9c5dc143db.js:1
Uncaught TypeError: Cannot call method 'app' of undefined 4179837:87
Best wishes, ClientEngage

Hi @ClientEngage (and any others having trouble seeing the License/Purchase box)

I’m having some trouble reproducing this problem. From those errors it looks like one or two JS files aren’t loading properly for you. Are you able to give me a bit more information about the browser/OS versions you’re using?

And are you using any browser extensions (AdBlock etc) that might be blocking things?

If you’re savvy with browser dev tools (sounds like you might be if you can see those errors :) ) can you check the Network tab and see if there is anything having trouble loading?

I’d like to get to the bottom of this one ASAP, I’ll be watching this thread :)

Ben

Hi Ben,

Thanks for taking the time to get back. :-)

I just had a look again. Refreshing an item page several (!) times recreates this for me, although it appears to happen more often when simply browsing around.

Anyhow, I can only see 304 and 200 status codes – so everything loads properly. That said: when it doesn’t work then there’s a missing XHR request to the following: marketplace.net/bookmarks/states?item_ids[]={ITEMID}

So it looks like, sometimes, the request is not being initiated. Maybe an onload event problem or similar. Moreover, I do use an ad blocker – even if that is the culprit, I’d think it should still work since I’m not the only person using one. :-)

All the best, ClientEngage

491 posts Code is Poetry
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Has been a member for 2-3 years
  • Europe
  • Exclusive Author
  • Referred between 50 and 99 users
  • Bought between 1 and 9 items
egemenerd says

This button looks weird;

Google Chrome, Win8

492 posts
  • Author had a File in a Mini Bundle
  • Author had a Free File of the Month
  • Elite Author
  • Exclusive Author
  • Sold between 100 000 and 250 000 dollars
  • Has been a member for 3-4 years
  • Referred between 200 and 499 users
+3 more
theAlThemist says

I have the same problem with the license/purchase box.

Also the comments section doesn’t work properly. The submit button doesn’t seem to work (at least this is how it looks as nothing happens when I clicked it).

However, when you refresh the page, the answer I made to a client’s comment was there (doubled as I clicked submit button twice).

Also the textarea (class=”js-comment-new-reply-field flexible-textarea”) doesn auto expand to take the content. It stays a single line while typing.

Win 8.1 Pro/FireFox 27.0.1

468 posts
  • Envato Staff
  • Envato Developer
  • Australia
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
  • Exclusive Author
justinfrench Dev says

Are previews broken on items too? Especially on the main page of each marketplace. Also looks like editing a post is broken too. It only shows the textbox with no layout.

Could you post a screenshot of both of these (along with the browser/os, etc).

112 posts
  • Envato Studio (Microlancer) Beta Tester
  • Europe
  • Exclusive Author
  • Has been a member for 1-2 years
Vlajki says

Just a small detail: the spinning loader icon is still your old logo :)

468 posts
  • Envato Staff
  • Envato Developer
  • Australia
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
  • Exclusive Author
justinfrench Dev says

Just a small detail: the spinning loader icon is still your old logo :)

Thanks, added to the list :)

89 posts Live. Love. ASAP
  • Elite Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
  • Bought between 10 and 49 items
  • Sold between 100 000 and 250 000 dollars
  • Exclusive Author
  • Most Wanted Bounty Winner
  • Author had a Free File of the Month
+1 more
liviu_cerchez says

Mark as read button margin

.comments-search-controls__mark-all-read { margin-bottom: 15px; }

491 posts Code is Poetry
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Has been a member for 2-3 years
  • Europe
  • Exclusive Author
  • Referred between 50 and 99 users
  • Bought between 1 and 9 items
egemenerd says


Mark as read button margin
.comments-search-controls__mark-all-read { margin-bottom: 15px; }

One more;

2024 posts
  • Elite Author
  • Author had a Free File of the Month
  • Has been a member for 4-5 years
  • Austria
  • Exclusive Author
  • Interviewed on the Envato Notes blog
  • Envato Studio (Microlancer) Beta Tester
+3 more
revaxarts says

and

\\

only if you have a five digits value though :)

73 posts
  • Most Wanted Bounty Winner
  • Sold between 5 000 and 10 000 dollars
  • Has been a member for 2-3 years
  • Bought between 1 and 9 items
  • Exclusive Author
  • Romania
tips4design says

and

\\

only if you have a five digits value though :)

I would be so annoyed to have my balance overflow its container :D

by
by
by
by
by
by