2324 posts
  • Has referred 100+ members
  • Has sold $40,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Helped several times protecting Envato Market against copyright violations
+6 more
CreativeMilk says

I am working with quicksand, and all things work but afther clicking the sort button the lightbox wont load the images any more and the lightbox goes black.

I have used the enhancement part to load the lightbox function, but the images will not work.

(the images will load if i haven’t clickt on the sort button)

Anybody any idea?

415 posts
  • Has referred 10+ members
  • Has sold $250,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
+5 more
unisphere says

You have an end callback in quicksand, this is where you’ll normally set the lightbox again:

jQuery('...').quicksand( {
    ...    
}, function(){
    // end callback
    SetLightbox();
});

The SetLightbox() function (in my case) inits the lightbox.

Let me know if you need any more help.

2324 posts
  • Has referred 100+ members
  • Has sold $40,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Helped several times protecting Envato Market against copyright violations
+6 more
CreativeMilk says

You have an end callback in quicksand, this is where you’ll normally set the lightbox again:
jQuery('...').quicksand( {
    ...    
}, function(){
    // end callback
    SetLightbox();
});

The SetLightbox() function (in my case) inits the lightbox.

Let me know if you need any more help.

i have used this, and this works perfect, but for some reason the lightbox goes black, so there no image loaded. In other words the lightbox does work but it dont load/display the images.

415 posts
  • Has referred 10+ members
  • Has sold $250,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
+5 more
unisphere says


You have an end callback in quicksand, this is where you’ll normally set the lightbox again:
jQuery('...').quicksand( {
    ...    
}, function(){
    // end callback
    SetLightbox();
});

The SetLightbox() function (in my case) inits the lightbox.

Let me know if you need any more help.
i have used this, and this works perfect, but for some reason the lightbox goes black, so there no image loaded. In other words the lightbox does work but it dont load/display the images.

That may be caused by a number of reasons, could you posts a link to the page in question?

2 posts
  • Has been part of the Envato Community for over 4 years
jaycbrf4 says

I had this problem as well. I asked the developer of Quicksand for help and he told me to learn javascript… I asked the developer of PrettyPhoto for help and the response was ” I don’t have time to fix Quicksand”

Issue Solved!!!!

Screw Quicksand and use jQuery Isotope http://isotope.metafizzy.co/

Just as good if not BETTER than Quicksand. Much easier to use, configure, and implement.

No callback required for prettyPhoto, it just works!

by
by
by
by
by
by