725 posts WordPress Ninja
  • Microlancer Beta Tester
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Most Wanted Bounty Winner
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 3-4 years
+2 more
TylerQuinn says

Hey all, I am working on a reponsive WordPress Theme, and am looking for a better testing solution than uploading to a server for testing. Right now I am developing on localhost and then pushing changes to a server to try with my iPhone / iPad.

While I can access pages localy using 192.168.1.xxx/wordpress-2/ none of the images or source files appear to be loading. The layout displays but no images, js, css etc. are loaded. Any idea why this could be happening?

Thanks much.

1582 posts Don't Worry, Be Happy
  • Beta Tester
  • Grew a moustache for the Envato Movember competition
  • Elite Author
  • United States
  • Sold between 250 000 and 1 000 000 dollars
  • Has been a member for 3-4 years
  • Referred between 200 and 499 users
  • Most Wanted Bounty Winner
+2 more
FinalDestiny says

If you’re on OS X , download XCode and use their iOS Simulator, it’s the closest one to simulate the real behaviour of iphone/ipad

367 posts plop
  • Elite Author
  • Sold between 50 000 and 100 000 dollars
  • Beta Tester
  • Has been a member for 4-5 years
  • Grew a moustache for the Envato Movember competition
  • Referred between 50 and 99 users
  • Interviewed on the Envato Notes blog
+3 more
kimonoThemes says

Using a vhost instead of the IP or “localhost” to install the WordPress. With a vhost it will be possible to connect from your iPad/iPhone if you’re on the same Wifi. On MacOSX for example it’s computer_name.local, so just going to http://computer_name.local:8888 (if using MAMP ) and install the WordPress via this url.

On Windows I think the almost the same, computer_name or something.

3058 posts
  • Community Superstar
  • Has been a member for 6-7 years
  • Won a Competition
  • Sold between 50 000 and 100 000 dollars
  • Bought between 10 and 49 items
  • Referred between 50 and 99 users
  • Exclusive Author
+1 more
wickedpixel says

Have you set on Wordpress setting the url of the website as 192.168. bla bla… or have you leave it as localhost? localhost is not good if you try it from other devices.

725 posts WordPress Ninja
  • Microlancer Beta Tester
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Most Wanted Bounty Winner
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 3-4 years
+2 more
TylerQuinn says

Have you set on Wordpress setting the url of the website as 192.168. bla bla… or have you leave it as localhost? localhost is not good if you try it from other devices.

Yeah I was using the local IP I ended up having to change the site URL etc. in the WP general settings and any references in the settings with localhost for images like sliders to the IP as well. All is good now.

by
by
by
by
by
by