15 posts
  • 5 Years of Membership
  • Collector Level 1
  • Exclusive Author
  • India
mistergiri
says

You can use all sort of plugins ( depend on the license ), but you can’t bundle it into your themes files.

Why not? For example, this is the plugin I would like to include.

http://wordpress.org/extend/plugins/single-post-template/

But as you can see that plugin hasn’t been updated in over 2 years. So recommending that plugin is a very bad idea.

So I would like to modify that plugin and include that in my theme.

In this file it says, GPL license.

http://plugins.trac.wordpress.org/browser/single-post-template/trunk/post_templates.php

So why can’t I use that in my theme?

1482 posts
  • Envato Team
  • Author Level 6
  • Meetup Participant
  • Affiliate Level 5
+14 more
kailoon
Envato team
says

The problem is user may not be able to update the plugins when there is a new release, or update for newer version of WP or getting notification of updates etc.

An outdated plugin, it may contain outdated codes and may not work in the latest WP.

15 posts
  • 5 Years of Membership
  • Collector Level 1
  • Exclusive Author
  • India
mistergiri
says

An outdated plugin, it may contain outdated codes and may not work in the latest WP.

As I said earlier, I would like to modify that plugin code and then include it in my theme.

1 post
  • 3 Years of Membership
  • Collector Level 2
  • Exclusive Author
  • Romania
ailovan
says

Hello,

So it’s ok to include with TGM a plugin like contact form 7?

Thank you.

124 posts
  • 4 Years of Membership
  • Affiliate Level 1
  • Author Level 3
  • Collector Level 1
+3 more
hainug
says

It’s ok, it’s also recommended to do that way.

251 posts
  • Top Monthly Author
  • Trendsetter
  • Weekly Top Seller
  • 5 Years of Membership
+8 more
ait
says


An outdated plugin, it may contain outdated codes and may not work in the latest WP.
As I said earlier, I would like to modify that plugin code and then include it in my theme.

If the plugin is GPL and you want to base your own plugin on it’s code you can take the plugin, extend it (!) and include in your theme. That’s one of the reasons people use GPL for their work.

127 posts
  • 2 Years of Membership
  • United States
  • Community Superstar
  • Author Level 5
+4 more
senorthemes
says

I was just wondering about this. Thanks for the great info guys! :)

1680 posts Chris Robinson
  • Elite Author
  • Author Level 10
  • 7 Years of Membership
  • United States
+13 more
contempoinc
says


You can use all sort of plugins ( depend on the license ), but you can’t bundle it into your themes files.

Why not? For example, this is the plugin I would like to include.

http://wordpress.org/extend/plugins/single-post-template/

But as you can see that plugin hasn’t been updated in over 2 years. So recommending that plugin is a very bad idea.

So I would like to modify that plugin and include that in my theme.

In this file it says, GPL license.

http://plugins.trac.wordpress.org/browser/single-post-template/trunk/post_templates.php So why can’t I use that in my theme?

That plugin was updated Apr, 4 2013 ;)

by
by
by
by
by
by