382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

So I bought this MP3 player to use on a client’s website: http://activeden.net/item/dynamic-mp3-player-xml/4051

I copied the exact code from the example HTML file that came with it into my HTML file, but I cannot get it to appear at all. It just plain doesn’t show up. I’ve double checked that the DIV I ’m placing it in is visible, because I can add other content to it and it appears. So, I was wondering if anyone could help me out here (I’m not a Flash guy at all, and haven’t really worked with it much either- obviously :) ).

Here is the site I’m trying to implement it on: http://www.travisjamesmusic.com/version2/index.php (click on the ‘Player’ tile on the bottom). It should show up underneath the ‘Player’ label when everything slides over, but it doesn’t. Feel free to look at the code for the page and see if I made a stupid mistake.

Thanks for any help!

1676 posts Envato Elite Author
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Author had a Free File of the Month
  • Exclusive Author
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Europe
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
+1 more
Tean says

Hi blabus!

You have changed the name of the div from ‘flashcontent’ to ‘playerContent’.

SWFObject.write() method tells SWFObject to proceed with embedding the SWF with that specified name.

Also, not sure if you have changed the name of the player swf file from ‘preview.swf’ to ‘Mp3 Player.swf’

382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

Hi blabus!

You have changed the name of the div from ‘flashcontent’ to ‘playerContent’.

SWFObject.write() method tells SWFObject to proceed with embedding the SWF with that specified name.

Also, not sure if you have changed the name of the player swf file from ‘preview.swf’ to ‘Mp3 Player.swf’

Yes! Thank you. I changed the parameter in the .write() method and now I’ve got the player showing. Next step is to figure out why none of the songs are being loaded. Any ideas on that? :)

1676 posts Envato Elite Author
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Author had a Free File of the Month
  • Exclusive Author
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Europe
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
+1 more
Tean says

Probably the xml file hasnt been read.

Have you been changing the content?

I noticed that you have moved the player from the root directory down to ‘player’ folder.

Try putting (just temporarily) xml file(s) related to player in the root of the site.

Leave them in the same folder in which they were before (if they were in the folder) just move it to the root.

382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

Yep, I thought of the same thing. Moving it all back to the root of the site fixed it.

Thanks again for all the help!

1676 posts Envato Elite Author
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Author had a Free File of the Month
  • Exclusive Author
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Europe
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
+1 more
Tean says

You dont neccesarrily need to move files back to the root, but if you move the files down from the root you need to change the path to the xml which is probably hardcoded in the code somewhere.

by
by
by
by
by
by