382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

I’ve been working on this website for a band, and it’s just about done:

http://www.labusdesign.com/travisjames/index.html

However, I can’t get the contact form to work. I created the form and added to PHP script, but when I fill it out and hit submit, I just get a 500 Internal Server Error.

Unfortunately I’m just about clueless when it comes to PHP (the script I got from webdesigndeluxe, and he verified that it works for him on his sites).

Thanks for any help!

1281 posts
  • Elite Author
  • Has been a member for 5-6 years
  • Sold between 100 000 and 250 000 dollars
  • Author had a Free File of the Month
  • Referred between 200 and 499 users
  • Bought between 10 and 49 items
  • Europe
  • Exclusive Author
+1 more
fuelthemes says

I think you should have sold that design on themeforest :)

164 posts
  • Bought between 10 and 49 items
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 5 000 and 10 000 dollars
  • United States
  • Won a Competition
hagdesigns says

Your server might not be configured for outgoing mail. Where are you testing this, locally or through a web host?

962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says

^^^^^^^ wow he’s good! :D

426 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 10 and 49 users
  • Sold between 5 000 and 10 000 dollars
  • United States
vasilios says

Whenever I get a 500 error it’s usually a CHMOD error. Make sure the file is CHMODed to 755. :)

Very nice design by the way!

382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

Thanks!

I’m testing it on my server- that link is exactly where it’s not working.

Unfortunately, if it’s anything other than HTML , CSS, or Javascript, I’m a complete newbie. How would I CHMOD the file to 755 (and which file do I CHMOD ?) :)

426 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 10 and 49 users
  • Sold between 5 000 and 10 000 dollars
  • United States
vasilios says

The CHMODing option is usually in your FTP client. :) You CHMOD the file that’s giving you the 500 error.

159 posts
  • Bought between 1 and 9 items
  • Europe
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 5 000 and 10 000 dollars
peex says

Open your ftp program en select the folder. Right click an select chmod then set it to 777. It will be different program to program.

164 posts
  • Bought between 10 and 49 items
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 5 000 and 10 000 dollars
  • United States
  • Won a Competition
hagdesigns says

You would need to use an FTP client or a file manager on your server to change permissions.

When you say “my server” do you mean on a web host like Media Temple, or do you mean like xampp with localhost, OR are you cool like me and roll your own dedicated linux servers :p?

382 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • United States
blabus says

No, I’m using Network Solutions web hosting.

Right now I’ve got it working, as I used Network Solutions’ form builder to create the script, and then adapted it for my page. However, it’s Perl, not PHP .

EDIT : I tried the PHP script again, using CyberDuck modified the permissions from 755 to 777, but I’m still getting the same 500 Internal Server error.

by
by
by
by
by
by