1547 posts
  • Has referred 50+ members
  • Has sold $125,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
Anps says

I think that also, since on my laptop windows 7 all is ok, here on pc win 7 its messed up

138 posts
  • Sells items exclusively on Envato Market
  • Has sold $1,000+ on Envato Market
  • Has been part of the Envato Community for over 6 years
  • Contributed a tutorial on Tuts+
+5 more
ram64 says

Do you have ClearType enabled? I disabled it and it looks worse, but still not like yours.

1121 posts
  • Has sold $10,000+ on Envato Market
  • Has been part of the Envato Community for over 2 years
  • Sells items exclusively on Envato Market
  • Has referred 100+ members
+2 more
TanyDi says

Did you notice that sizes look like this 2000×3000 px instead of 2000 x 3000 px ? There are must be two free spaces between number and x ….. even in the banner up I see this letter ( it’s one of my language so I think that maybe you see something else ) instead of X. Is this only a problem for me ?

wordpress-premium
wordpress-premium Recent Posts Threads Started
22 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 200+ members
  • Has sold $1,000+ on Envato Market
  • Has collected 10+ items on Envato Market
wordpress-premium says

Don’t like it. For now small size font looks bad (to much blurred). FF, Opera, and IE10+ brings much better result.

905 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Had an item featured in an Envato Bundle
  • Had an item featured on Envato Market
+4 more
JohnRosso says

use Opera now. Love it.

240 posts
  • Has sold $1,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Located in Serbia
BrancoG says

I hate Chrome,Opera and Firefox are much better.

221 posts The Joomla Guy
  • Power Elite Author: Sold more than $1M on Envato Market
  • Won a competition
  • Had an item featured on Envato Market
  • Made it to the Authors' Hall of Fame
+9 more
hogash says

I won’t have any issues with loading however i have an issue , check the screenshot. For example on my laptop i don’t have a problem, what could go wrong? Maybe a setting in windows?

\\

Me too, i’ll try uninstalling Helvetica Neue since i’m on a Win PC and i think that’s the actual problem.

110 posts
  • Has sold $5,000+ on Envato Market
  • Won a Most Wanted contest
  • Sells items exclusively on Envato Market
  • Has been part of the Envato Community for over 2 years
+3 more
tips4design says

Don’t like it. For now small size font looks bad (to much blurred). FF, Opera, and IE10+ brings much better result.

Same, I updated hoping for clear text (not jittery as the previous one) but now it is way too blurry for my eyes. :(

316 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
FalconFX says

its not good for me, i used a workaround to go back to 36, it looks like it has problems with displays that has high DPI, everything in it is zoomed in :(

110 posts
  • Has sold $5,000+ on Envato Market
  • Won a Most Wanted contest
  • Sells items exclusively on Envato Market
  • Has been part of the Envato Community for over 2 years
+3 more
tips4design says

its not good for me, i used a workaround to go back to 36, it looks like it has problems with displays that has high DPI, everything in it is zoomed in :(

Found a solution here: https://productforums.google.com/forum/#!topic/chrome/17kfuau1ApM%5B1-25-true%5D

[blockquote] Go to your Chrome shortcut’s properties (right click Chrome icon, go to Properties). Then in the “Target:” field, add /high-dpi-support=1 /force-device-scale-factor=1 right after the closing quotation marks currently in that field. Make sure there’s a space right after the closing quotation before you input the new text. Click Apply , Restart Chrome. [/blockquote]

by
by
by
by
by
by