438 posts
  • 4 Years of Membership
  • Exclusive Author
  • United States
christopherjon
says

Anybody have a handy cleartype fix for the nivo slider?

I couldn’t find anything via search.

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

What do you mean exactly? The choppy look on IE’s ?

This occurs because of the opacity property (filter on IE).

Applying a background attribute should fix it

438 posts
  • 4 Years of Membership
  • Exclusive Author
  • United States
christopherjon
says

Yeah,

IE’s poor rending of fading and fonts. It’s a known IE jquery bug but I couldn’t find anything regarding fixing it with nivo.

I spent a couple hours of playing with the code to get nivo to include post titles, excerpts and all of that fun stuff like a proper slider should but the text rending makes it unusable.

jquery isn’t something I’m very familiar with.

Where should I apply the background attribute?

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

I think it’s the caption

.nivo-caption, .nivo-caption p{
    background:#000 !important;
}

But you will lose the opacity…

206 posts
  • 6 Years of Membership
  • Affiliate Level 3
  • Author Level 6
  • Collector Level 3
+4 more
mlando
says

I ran in to this problem also and found that a background color on the .nivo-caption solves it… BUT that really sucks. Would love it if anyone had a better option.

16 posts
  • Affiliate Level 2
  • Author Level 7
  • Collector Level 1
  • Weekly Top Seller
+4 more
dwoolf
says

I ran in to this problem also and found that a background color on the .nivo-caption solves it… BUT that really sucks. Would love it if anyone had a better option.

I’m not sure about the Nivo issue, but I do know that adding

background-color: transparent;

has helped with some text rendering issues I have had with IE. That way, you wouldn’t be stuck with a solid color, etc.

206 posts
  • 6 Years of Membership
  • Affiliate Level 3
  • Author Level 6
  • Collector Level 3
+4 more
mlando
says
background-color: transparent; has helped with some text rendering issues I have had with IE. That way, you wouldn’t be stuck with a solid color, etc.

thanks, tried that… didn’t work too well for me… still a bit jaggy in IE

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

There is actually no good workaround for this:

  • don’t use opacity
  • use a background
  • remove the filter attribute (causes no opacity in IE)
removing the filter:
$('#box').animate(
    {opacity:1},
    function() {
        $(this).css('filter','');
    }
);

I didn’t tried a transparent background image (png) maybe that works

by
by
by
by
by
by