2254 posts Digital Artist
  • Had an item featured in a magazine
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has referred 200+ members
+12 more
crozer says

Hey,
I hope you could give me a hand, as this is quite strange:

As you can see, the text has been morphed into symbols. This behavior, I think, only happens on my laptop, as I haven’t experienced it before. The image above shows three different screenshots; the first and the second were taken from my theme’s tag cloud and a PSDTuts tutorial accordingly (these symbols do not disappear even after refreshing the page, etc.); the third is a screenshot of a marketplace (this however, after the site fully loads, disappears).

Another thing that happens to me, is when I attempt to upload an image to www.tinypic.com and write the CAPTCHA code: what I write is symbolized. Have a look and please try it yourself, too:

The symbols do represent what I am writing, because when I then hit ‘upload now’, the CAPTCHA does recognize what I’ve written.

Any ideas? I assume it could be related to Cufón, as my theme’s tag cloud, Tuts+ and the marketplaces consist of several cufón-headings.

Thanks a lot :)
Chris

2468 posts
  • Has been part of the Envato Community for over 5 years
  • Has sold $100+ on Envato Market
  • Has referred 100+ members
  • Has been a beta tester for an Envato feature
+2 more
digitalimpact says

It’s not related to Cufon. (Cufon-replaced text can’t even be selected nor used as body/input text)

Anyway, I bet you’re using Firefox, so here’s the answer to your problem.

To all the lazy ones that want a quick answer: Firefox has problems rendering Helvetica/Geneva in certain (larger sizes). Try and set the font-size smaller with Firebug and you’ll see it works ;)

EDIT : another solution would be to unistall those fonts from your system, though that sucks since we all love Helveeeetica :D

P.S.: Tuts+ uses the much-better @font-face ;)

308 posts
  • Has referred 1+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+4 more
brainbuzzmedia says

How can you use @font-face without it looking jagged?

2468 posts
  • Has been part of the Envato Community for over 5 years
  • Has sold $100+ on Envato Market
  • Has referred 100+ members
  • Has been a beta tester for an Envato feature
+2 more
digitalimpact says
How can you use @font-face without it looking jagged?

I don’t think you can. However, I prefer to use @font-face and let users be able to select text. Not to mention all the canvas elements Cufon bloats your code with…

I know Cufon is popular, this is just my (and Tuts+’s) point of view…

2254 posts Digital Artist
  • Had an item featured in a magazine
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has referred 200+ members
+12 more
crozer says

Amazing digitalimpact, I can most definitely remove that annoying Helvetica; it is not the original one (I got a kind of corrupt, cheap Helvetica).

Thanks mate! Really appreciate it.

2468 posts
  • Has been part of the Envato Community for over 5 years
  • Has sold $100+ on Envato Market
  • Has referred 100+ members
  • Has been a beta tester for an Envato feature
+2 more
digitalimpact says

No problem mate :)

I was also pissed back when I had Helvetica and some sites looked unreadable. Now I only use it sporadically…

Sad part is that this issue is an old one and Mozilla still haven’t fixed it :(

1029 posts
  • Has referred 500+ members
  • Has sold $500,000+ on Envato Market
  • Has collected 50+ items on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
+6 more
ThemeBlvd says
How can you use @font-face without it looking jagged?

I don’t think you can. However, I prefer to use @font-face and let users be able to select text. Not to mention all the canvas elements Cufon bloats your code with…

I know Cufon is popular, this is just my (and Tuts+’s) point of view…

If IE would just render text nicely, we could all use @font-face and the world would be so much easier to live in… One day, my friends, one day…

2254 posts Digital Artist
  • Had an item featured in a magazine
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has referred 200+ members
+12 more
crozer says

Hey,
I thought I would manage to fix this issue by reinstalling a stable, original and ‘clean’ version of Helvetica (from Adobe Fontfolio 11).

I got Adobe FF 11 , and installed all versions of Helvetica available (from LT STD , Helvetica Neue to the initial version). I restarted my system, refreshed and cleared all my Firefox’s cache in the hope of fixing this issue, but it still shows up – exactly as it did before.

Any thoughts? I can read and appreciate the beauty of Helvetica from my PC (throughout the Web), but it really sucks that on my Laptop, when checking my themes and other sites, everything looks so odd and chaotic.

I don’t think the only solution is to remove Helvetica or to adapt my Firefox or even switch back to Arial (font-family: Arial, Helvetica..) – I want and need to be able to create themes again with this font, for everyone to see equally.

Thank you very much in advance :)
Chris

2468 posts
  • Has been part of the Envato Community for over 5 years
  • Has sold $100+ on Envato Market
  • Has referred 100+ members
  • Has been a beta tester for an Envato feature
+2 more
digitalimpact says

As I said, this is not related to your font being broken or not.

It’s a Firefox issue – the browser simply can’t render it in some (apparently larger) sizes.

So until Mozilla address this issue, there’s not much you can do.

Works fine in other browsers though…

1479 posts The right tools with none of the gimmicks
  • Has referred 50+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+6 more
PixelBin says

Have you tried messing around with the Encoding in Firefox’s settings? That may solve your problem if you say it only happens on your laptop.

In Firefox, View > Character Encoding > Try changing it and see if it makes a difference.

Helpful Information

  • Please read our community guidelines. Self promotion and discussion of piracy is not allowed.
  • Open a support ticket if you would like specific help with your account, deposits or purchases.
  • Item Support by authors is optional and may vary. Please see the Support tab on each item page.

Most of all, enjoy your time here. Thank you for being a valued Envato community member.

Post Reply

Format your entry with some basic HTML. Read the Full Details, or here is a refresher:

<strong></strong> to make things bold
<em></em> to emphasize
<ul><li> or <ol><li> to make lists
<h3> or <h4> to make headings
<pre></pre> for code blocks
<code></code> for a few words of code
<a></a> for links
<img> to paste in an image (it'll need to be hosted somewhere else though)
<blockquote></blockquote> to quote somebody

:grin: :shocked: :cry: Complete List of Smiley Codes

by
by
by
by
by
by