62 posts
  • Has been part of the Envato Community for over 2 years
  • Has sold $250,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
+3 more
cssignitervip
says

Been using beta and rc and everything seems fine. No major headaches I think.

I am bit concerned about the language selection during WordPress setup. I mean, it’s a great feature but I hope users won’t expect their themes to be translated in all these languages as well. Time will tell :)

41 posts
  • Located in Romania
george-olaru
says

Just a small hint for the authors that are using any kind of custom plugins that open a pop-up (eg. shortcodes, visual composer) in the post editor – in 4.0 they increased the CSS z-index rule of the Editor Toolbar – so you may need to increase it too.

326 posts
  • Has been part of the Envato Community for over 2 years
  • Has referred 10+ members
  • Has sold $40,000+ on Envato Market
  • Sells items exclusively on Envato Market
+1 more
subsolar
says

Little off: Hi, Andrew. Cool news that you are part of the Envato team. I’ve been a long fan of your blog for a long time. Welcome!

117 posts
  • Became a Top 20 Author of the Month
  • Elite Author: Sold more than $75,000 on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 5 years
+6 more
2winFactor
says

Is it possible to add 4.0 to the compatibility list when WordPress is updated? Sometimes it takes up to a week to change the compatibility options for theme pages on Themeforest. I actually get most of the questions on the topic right away, so it would be great to have that option sooner and cut down on those types of questions!

443 posts Codestar
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $250,000+ on Envato Market
  • Became a Top 20 Author of the Month
  • Sells items exclusively on Envato Market
+8 more
Codestar
says

Is it possible to add 4.0 to the compatibility list when WordPress is updated? Sometimes it takes up to a week to change the compatibility options for theme pages on Themeforest. I actually get most of the questions on the topic right away, so it would be great to have that option sooner and cut down on those types of questions!

Yes it is available since 1 week :D

101 posts
  • Has been part of the Envato Community for over 2 years
  • Has sold $100+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Sells items exclusively on Envato Market
QUAL
says

My greatest fear was another major change in for wp.media. It seems it doesn’t have any functional change (at least for how I use it)

I checked metaboxes, admin functions, shortcodes, and nothing is broken in my new project. Have you found any major feature changed, so we can all test?

This can’t even be a sub version, why a major version? I don’t understand.

117 posts
  • Became a Top 20 Author of the Month
  • Elite Author: Sold more than $75,000 on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 5 years
+6 more
2winFactor
says

My greatest fear was another major change in for wp.media. It seems it doesn’t have any functional change (at least for how I use it)

I checked metaboxes, admin functions, shortcodes, and nothing is broken in my new project. Have you found any major feature changed, so we can all test?

This can’t even be a sub version, why a major version? I don’t understand.

Major versions add new features, where as sub versions are for bug fixes:

http://make.wordpress.org/core/handbook/how-the-release-cycle-works/version-numbering/
1059 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+5 more
Gareth_Gillman
says

I have had one client site break due to the upgrade but I think it was because they were using 3.7 and upgraded to 4.0 and it broke with the error message:

PHP Fatal error: Cannot redeclare like_escape()

The Like Escape string was depreciated in 4.0.

I renamed the active theme and didn’t fix, renamed the plugin folder and didn’t work, so uploaded new files from 4.0 and it fixed it, not 100% sure why it broke (or what function in WP caused it) but not seen any other site get the same error.

by
by
by
by
by
by