19 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • United States
schmackLab says

Hey everybody,

I just a finished a new theme for a personal site and while the theme has uploaded and appears to function I got these errors on the upload.

Warning: fopen(/home1/schmackl/public_html/wp-content/themes/schmackLab-v1.0/style.css) [function.fopen]: failed to open stream: No such file or directory in /home1/schmackl/public_html/wp-includes/functions.php on line 3598

Warning: fread(): supplied argument is not a valid stream resource in /home1/schmackl/public_html/wp-includes/functions.php on line 3601

Warning: fclose(): supplied argument is not a valid stream resource in /home1/schmackl/public_html/wp-includes/functions.php on line 3604

Even though the theme works I am worried about these errors since I installed last week put up a ton of content and then had an explicable data base crash (possibly due to plugins, not really sure).

I had to delete the database and start over and would like avoid another catastrophe down the line.

Thanks for you help I’ve gad no luck finding a solution on the Wordpress forums.

155 posts
  • Bought between 10 and 49 items
  • Canada
  • Exclusive Author
  • Has been a member for 4-5 years
Warll says

functions.php is trying to open a file that does not exist. It shouldln’t harm the DB but it will likely break some of the theme’s functionality.

19 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • United States
schmackLab says

Any idea how to fix it?

19 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • United States
schmackLab says

I found this plugin authors comments regarding the same error under different circumstances.

A lot of you have commented and e-mailed me regarding an fopen PHP error that occurs during the usage of one of my plugins. The reason for this is because of your PHP configurations, editted by your web host. Your web host must have disabled URL file-access, which is the method I use to retrieve the plugin support link which is displayed on my plugins, which you have an option to enable/disable.

It took a while, but I’ve released an update to every plugin I’ve released. In this update, I no longer use the fopen command. I use cURL instead, which should solve the problem for the users which have this issue.

If this is a problem with my host (bluehost) do I need to worry about it? Thanks for any help.

155 posts
  • Bought between 10 and 49 items
  • Canada
  • Exclusive Author
  • Has been a member for 4-5 years
Warll says

It sounds like you only need to update the plugin.

19 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • United States
schmackLab says

It’s not the plugin. i don’t have that plugin installed they just had a similar experience and is the only place I have found anything resembling a solution.

155 posts
  • Bought between 10 and 49 items
  • Canada
  • Exclusive Author
  • Has been a member for 4-5 years
Warll says

Then fix functions.php to not use ‘fopen’.

by
by
by
by
by
by