1032 posts Massfocus
  • Elite Author
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 500 and 999 users
  • Author had a File in an Envato Bundle
  • Beta Tester
+3 more
Massfocus says

I just installed and ran this script for the first time today, i watched the tutorial video and redid all the expressions from scratch without renaming them and ran it. It came with this error … https://dl.dropbox.com/u/4361753/expressionerror.jpg Does anyone have a idea what it is? i am totally new with this script and have no idea what its saying.

3904 posts After Effects Templates
  • Sold between 100 000 and 250 000 dollars
  • Exclusive Author
  • Elite Author
  • Referred between 500 and 999 users
  • Bought between 100 and 499 items
  • Envato Studio (Microlancer) Beta Tester
  • Beta Tester
  • Has been a member for 4-5 years
+4 more
miseld says

Check “master comp” – > Text 5 precomp -> property color :) maybe you misspelled something, btw i hope Guru is here somewhere around, your call Ben.

1032 posts Massfocus
  • Elite Author
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 500 and 999 users
  • Author had a File in an Envato Bundle
  • Beta Tester
+3 more
Massfocus says

This screenshot is a bit outdated in the fact i renamed and remade all the layers. So the null layer, effects have all their original names and it still gives me the same error. And it does so for all text layers ..

I’m using the fill effect for the coloring.

7208 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 10 000 and 50 000 dollars
  • Envato Studio (Microlancer) Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Author had a Free File of the Month
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
+1 more
doru says

maybe you should engage the caps lock as the script recommends. I don’t know how the script works internally but it appears it takes ever comp one by one and probably keeps track of how expressions are referencing other stuff in other comps.

If the caps lock is not on then, when the script opens a composition to make the changes, the comp will update itself and ae will throw that error because the expression had been changed by the script universalizer at some moment and the script didn’t had the time to update the reference or something.

But I think is more probable that you just made a mistake in that expression before starting the script

I used the fill effect and ExpressionUniversalizer had no problem with that expression.

1032 posts Massfocus
  • Elite Author
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 500 and 999 users
  • Author had a File in an Envato Bundle
  • Beta Tester
+3 more
Massfocus says

maybe you should engage the caps lock as the script recommends. I don’t know how the script works internally but it appears it takes ever comp one by one and probably keeps track of how expressions are referencing other stuff in other comps.

If the caps lock is not on then, when the script opens a composition to make the changes, the comp will update itself and ae will throw that error because the expression had been changed by the script universalizer at some moment and the script didn’t had the time to update the reference or something.

But I think is more probable that you just made a mistake in that expression before starting the script

I used the fill effect and ExpressionUniversalizer had no problem with that expression.

Thanks for the input did all you suggested already and still got the same error. I’m simply pickwhipping one fill effect to another, maybe it conflicts with 2 of the same effect? i will try another method if thats the case.

EDIT think i got it, simply used color control instead of another fill effect and it is working on the layers with color control. Sorry for the newbie mistake.

7208 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 10 000 and 50 000 dollars
  • Envato Studio (Microlancer) Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Author had a Free File of the Month
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
+1 more
doru says

did you used the effect under Expressions Control -> Color Control for the effect that controls the other layers?

9 posts
  • Bought between 50 and 99 items
  • Has been a member for 5-6 years
  • Referred between 50 and 99 users
  • Sold between 100 and 1 000 dollars
aescripts says

From looking at your image it looks like the Fill effect is renamed -> Fill 3 which is probably why it’s giving the error. The only effects that can be renamed are the Expression Controls.

1032 posts Massfocus
  • Elite Author
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 500 and 999 users
  • Author had a File in an Envato Bundle
  • Beta Tester
+3 more
Massfocus says

did you used the effect under Expressions Control -> Color Control for the effect that controls the other layers?

Yes, this is what i am using now.

1032 posts Massfocus
  • Elite Author
  • Exclusive Author
  • Sold between 50 000 and 100 000 dollars
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • Referred between 500 and 999 users
  • Author had a File in an Envato Bundle
  • Beta Tester
+3 more
Massfocus says

From looking at your image it looks like the Fill effect is renamed -> Fill 3 which is probably why it’s giving the error. The only effects that can be renamed are the Expression Controls.

Thanks for the clarification, that is exactly what i did also. Renamed them from custom names to the duplicated default names. Also recreated them from scratch then they get the same name “fill” “fill 2” “fill 3” etc. Then i also got the error tho..

But i am using expression controls from now on problem solved, thanks again for all your input everyone.

by
by
by
by
by
by