4140 posts
  • Bought between 1 and 9 items
  • Brazil
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 1 and 9 users
  • Sold between 5 000 and 10 000 dollars
tsafi says

I am using FF and as a fan of noscript.net/( js block) is a mandatory use for me, most FF use it to block all the crap flash and js .

Thing is it block Font-face when i disable my js with noscrip i don’t understand why, i try to find a way to work around via css but no go and i cant use any js code obviously ,any input will be appreciate.

5310 posts The Dude Abides
  • United States
  • Exclusive Author
  • Has been a member for 5-6 years
  • Elite Author
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Author had a Free File of the Month
+5 more
CodingJack says

I don’t experience this behaviour with Google Fonts + FF 10 .0.2

Is your font-face a Google font?

4140 posts
  • Bought between 1 and 9 items
  • Brazil
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 1 and 9 users
  • Sold between 5 000 and 10 000 dollars
tsafi says

Hey C, I am not talking about goggle Api font from Google’s font library, but on @font-face directly embed from fontsquirrel then apply it on my css .

so with font-face if my noscript enable it will kill my @font-face,i cant understand why it’s killing it as there is no js at all and the noscript extension kill my font face if enable on my FF

5310 posts The Dude Abides
  • United States
  • Exclusive Author
  • Has been a member for 5-6 years
  • Elite Author
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Author had a Free File of the Month
+5 more
CodingJack says

Hey C, I am not talking about goggle Api font from Google’s font library, but on @font-face directly embed from fontsquirrel then apply it on my css . so with font-face if my noscript enable it will kill my @font-face,i cant understand why it’s killing it as there is no js at all and the noscript extension kill my font face if enable on my FF

Send me the fontsquirel zip and I’ll see if I can reproduce the same behaviour.

4140 posts
  • Bought between 1 and 9 items
  • Brazil
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 1 and 9 users
  • Sold between 5 000 and 10 000 dollars
tsafi says

^I can’t believe i just notice it … any way i look hard and there is no work around it,look like its old issue …

http://hackademix.net/2010/03/24/why-noscript-blocks-web-fonts/
5310 posts The Dude Abides
  • United States
  • Exclusive Author
  • Has been a member for 5-6 years
  • Elite Author
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Author had a Free File of the Month
+5 more
CodingJack says

I wonder if Google Webfonts maybe considered a “trusted” source and that’s why it worked for me?

4140 posts
  • Bought between 1 and 9 items
  • Brazil
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 1 and 9 users
  • Sold between 5 000 and 10 000 dollars
tsafi says

I wonder if Google Webfonts maybe considered a “trusted” source and that’s why it worked for me?
Maybe on your option noscript extension your @font-face is off check ?

Again this issue is with @font-face and not with Google Webfonts which need js any way

by
by
by
by
by
by