41 posts
  • Bought between 10 and 49 items
  • Has been a member for 5-6 years
  • United States
cmF says

Hey everyone, just wondering why /wp-includes directories are being indexed on my site? It’s kind of embarrassing that you can see various directories and their contents:

/wp-includes/SimplePie
- Author.php
- Cache.php
- Cache/
- Caption.php
- Category.php
- Content/
- Copyright.php
ETC.

So what happened? My site runs fine but did I install it incorrectly? And how do I fix this? Thanks!

217 posts
  • Elite Author
  • Author had a File in an Envato Bundle
  • Sold between 100 000 and 250 000 dollars
  • Referred between 200 and 499 users
  • Exclusive Author
  • Bought between 1 and 9 items
  • Has been a member for 2-3 years
  • Europe
ichurakov says
2954 posts
  • Australia
  • Community Moderator
  • Elite Author
  • Author had a Free File of the Month
  • Most Wanted Bounty Winner
  • Author had a File in an Envato Bundle
  • Has been a member for 5-6 years
  • Contributed a Blog Post
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+10 more
dtbaker Volunteer moderator says

You need to turn off directory indexing.

Ask your hosting provider

or if you are familiar with editing .htaccess files you can try adding Options -Indexes to it.

1 post
  • Has been a member for 0-1 years
danial32 says

You can bloack those pages with robots.txt . Bloacks with bots will not index any url which you listed in that file.

365 posts
  • Envato Studio (Microlancer) Beta Tester
  • Grew a moustache for the Envato Movember competition
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred more than 2000 users
  • Bought between 100 and 499 items
  • Sold between 1 000 and 5 000 dollars
krafti says

check out google webmastertools robots.txt, Disallow: /wp-includes/

10 posts
  • Exclusive Author
  • Has been a member for 2-3 years
  • Referred between 1 and 9 users
  • Bought between 1 and 9 items
  • Sold between 1 000 and 5 000 dollars
  • Indonesia
awan_move says

you could use robots.txt to dissallow: wp-includes/ wp-admin/

or you could put htaccess with : Options -Indexes on wp-includes directory

by
by
by
by
by
by