619 posts
  • Exclusive Author
  • Has been a member for 1-2 years
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Bought between 1 and 9 items
  • Referred between 10 and 49 users
  • Europe
abstract-labs says

Hey guys, this morning, after a Chrome auto update ( Version 30.0.1599.66 m ), I’m having some problems with an embedded Google map… the map gets stuck on loading, I can’t pan/zoom anymore… anyone having the same problem?

Thanks :)

619 posts
  • Exclusive Author
  • Has been a member for 1-2 years
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Bought between 1 and 9 items
  • Referred between 10 and 49 users
  • Europe
abstract-labs says

Here is the message in the console: Uncaught SecurityError: Blocked a frame with origin “https://maps.google.it” from accessing a frame with origin “http://www.mysite.com”. The frame requesting access has a protocol of “https”, the frame being accessed has a protocol of “http”. Protocols must match.

I’m literally killing google with my searches but I haven’t been able to find a solution… maybe I should use the javascript google api?

Also I’ve seen a few site templates on sale here having the same problem…

1179 posts How's the surf doing?
  • Forum Superstar
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • United Kingdom
  • Referred between 200 and 499 users
  • Exclusive Author
  • Has been a member for 3-4 years
+2 more
tommusrhodus says

Try adding &output=embed to the end of your iFrame URL, or use GoMap;

http://www.pittss.lv/jquery/gomap/
619 posts
  • Exclusive Author
  • Has been a member for 1-2 years
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Bought between 1 and 9 items
  • Referred between 10 and 49 users
  • Europe
abstract-labs says

Hey mate thanks very much for your reply, &output=embed is already there.

This problems also happens on one of your site templates: Other, I haven’t checked more. Check it out with Chrome, can you see the problem in the Contact section where the map is? What version of Chrome have you got?

Regarding GoMap I’m trying to make it working, but do I need to get a Google Api Key first?

Apparently even embedding a simple iframe map has become a problem :(

619 posts
  • Exclusive Author
  • Has been a member for 1-2 years
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Bought between 1 and 9 items
  • Referred between 10 and 49 users
  • Europe
abstract-labs says

It is obvious that this is an iframe issue rather then Google Maps itself, maybe a Mod could edit the thread title to make it more appropriate?

The message in the console is quite clear: an https frame (in my case the google maps iframe) is called in an http page, the two protocols do not match and this causes an error… I’ve tried the following:

from <iframe src="https://maps.google... etc."> to http://maps.google... and this //maps.google.... but it didn’t work…

:S

1 post
  • Belgium
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 4-5 years
NicoJuicy says

I have the same problem with Chrome (it seems to be a new problem). Some collegues aren’t able to run it also in Chrome…

In Firefox and IE everything works. Chrome silently breaks this “protocol mismatch” :s

Not exactly awesome for a “popular” browser, i can’t embed Google business Photos

20 posts
  • Exclusive Author
  • Has been a member for 3-4 years
  • Referred between 1 and 9 users
  • Sold between 10 000 and 50 000 dollars
  • South Africa
promola says

Hey guys, this morning, after a Chrome auto update ( Version 30.0.1599.66 m ), I’m having some problems with an embedded Google map… the map gets stuck on loading, I can’t pan/zoom anymore… anyone having the same problem? Thanks :)

You’re not alone/We are not alone :(

http://productforums.google.com/forum/#!topic/maps/hQhwWA56NbA

This sucks!

43 posts
  • Turkey
  • Exclusive Author
  • Has been a member for 1-2 years
YTolun says

I uploaded a Symphony theme and it has the same problem. It isn’t reviewed yet, i wrote that it is a Chrome bug in the notes section. Hope it won’t be an issue.

1 post
  • Has been a member for 0-1 years
saronson417 says

Same issue for me. Nothing fancy with my setup, stopped working in Chrome after update. Still works in IE.

619 posts
  • Exclusive Author
  • Has been a member for 1-2 years
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Bought between 1 and 9 items
  • Referred between 10 and 49 users
  • Europe
abstract-labs says

I’ve found the solution in my case by creating a Javascript Google Maps Api Key, with this feature the map will display without any problem and also I could create a custom map to display my client name and address when clicking the marker on the map. ;)

If your problem is with Google Maps go here: https://developers.google.com/maps/ and follow the instructions to create and use the Api Key.

by
by
by
by
by
by