1055 posts Massfocus
  • Top Monthly Author
  • Trendsetter
  • Weekly Top Seller
  • Elite Author
+10 more
Massfocus
says

I’m asking you guys since i am sure one of you sound engineers came across this issue one time in your life. At least, this is what i hope :D

Yesterday i bought my high end gaming headset (s-series 7h) and it came with a USB Soundcard included, so i can choose to connect it with or without it, it’s made so you have good sound wherever you go.

Anyway the problem lies with its microphone since when i plug it in with the USB Soundcard enabled i get this high end pitch sound in the background which is super annoying, i cant call anyone with this. Please if anyone has a setting or a tip i overlooked please share, i hope this sound is familiar to some of you. Weird thing is, when i connect the headset without the included usb soundcard i have no noise, but the sound is so low and so bad that even if i crank up the volume to max it still sounds like i’m underwater or in a room next door.

Here are 2 samples of the noise i mean.

http://dl.dropbox.com/u/4361753/Hallo-%20WITHOUT%20USB%20soundcard.wma http://dl.dropbox.com/u/4361753/Hallo-with%20USB%20soundcard.wma

I hope i can ask this question here, i’ve scoured google for like 5 ~ 6 hours yesterday without a solution.. support is closed on weekends so i have to wait untill monday anyways, just figured i could try this forum.

Much love, Massfocus

822 posts
  • Top Monthly Author
  • Featured Author
  • Most Wanted Winner
  • 3 Years of Membership
+3 more
FxProSound
says

Try to change USB port or swap USB cable for another one (best with filters like these from scanners)

by
by
by
by
by
by