751 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has collected 10+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
CyberShot says

I am designing a wordpress theme on my computer for a company. I have wamp installed. I went into the admin area and changed my permalink to custom using / postname / So now when I go to add a page and I type the name of the page, it shows up underneath the page title with the correct link structure and the edit button appears to change the link. This is all good. That’s what I would expect. But when i go to the homepage and click the about button, or contact or anything else. I get an error saying “the requested url was not found on the server” Any ideas?

39 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 10+ members
  • Has sold $100+ on Envato Market
  • Located in Canada
+2 more
simonk says

Probably have your .htaccess file done wrong. If you make the file have full read/write access Wordpress can properly build it.

751 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has collected 10+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
CyberShot says

how do you change the read write process in the file

751 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has collected 10+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
CyberShot says

I figured it out. I had just / postname / as the custom option. it worked when I added index.php.

index.php/ postname /

this is version 2.7.1
by
by
by
by
by
by