751 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • United States
CyberShot says

I bought a theme and I am trying to get it up and running fully with content. My problem is that the sidebar widgets aren’t showing. there is suppose to be a search box, categories, and recent posts. Only the search box shows up. everything is there on the live preview and I have viewed the source code and it looks the same as mine except it stops after the search box. The footer and everthing else show up fine. So I am wondering if there is a setting somwhere that I don’t know about?

I emailed the theme author a few days ago and haven't heard back yet. that is why I am making this post. I don't have a live link to show you yet.

I see this code in the sidebar.php

http://pastie.org/431421

So how do I tell wordpress that the function exists? That code shows just below the search box. then i get the footer. So the stuff in the dynamic_sidebar is missing from my theme.
14 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Poland
  • Sold between 1 000 and 5 000 dollars
missyseepy says

If you want to enable widgets on your sidebars, you need to include some code in functions.php and sidebar.php files.

There’s a lot of tutorials about this online, one of them is http://bavotasan.com/tutorials/how-to-widgetize-your-wordpress-sidebar/ – easily explained. Or you can watch one of the “Wordpress for Designers” screencasts here on TF blog ;)

751 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • United States
CyberShot says

that code is present in the theme files already.

22 posts
  • Bought between 1 and 9 items
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
bocaj says

In my (brief) experience with wordpress, I’ve always had to disable the sidebar widgets, and then re-enable them for them to start working.

Whether this is default behaviour, or due to some kind of caching plugin/option i couldn’t tell you.

751 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • United States
CyberShot says

yes, but how do you do that?

1 post
  • Exclusive Author
  • Has been a member for 5-6 years
IndieGo says

Are you sure those widgets are all active? You can check under the Appereance -> widgets menu on your WP admin panel

316 posts
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Has been a member for 5-6 years
  • Exclusive Author
  • Interviewed on the Envato Notes blog
  • Referred between 200 and 499 users
  • Bought between 100 and 499 items
imaginem says

I think IndieGo said it right.

You need to add the widgets you prefer to the sidebar. You can do it from your wordpress admin > Appearance > Widgets. Just drag and drop it to the sidebar displayed on the right.

The source from your link simply says to look for any widgets you’ve added to the dynamic sidebar.

Hope this was helpful.

cheers.

by
by
by
by
by
by