350 posts Gambit
  • Has been part of the Envato Community for over 5 years
  • Has referred 10+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has collected 100+ items on Envato Market
+4 more
bfintal
says

Authors, how do you do your testing for multiple WP versions? When I started selling, There was only WP 3 .0, now it’s WP 3 .1.2!

How do you setup your environment to test for all these versions? I’m wondering because the different versions may have differences in the database structure so there’ll be multiple database instances, and I’ll need to copy over all the content to each WP version’s database.

679 posts Cudazi
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has been part of the Envato Community for over 6 years
  • Has sold $250,000+ on Envato Market
  • Has referred 500+ members
+11 more
cudazi
Envato team
says

The older versions are stored here: http://wordpress.org/download/release-archive/

3439 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Achieved the monthly Community Superstar Award
  • Located in United States
+2 more
organicbee
says

local server multiple versions installed, or a VM

350 posts Gambit
  • Has been part of the Envato Community for over 5 years
  • Has referred 10+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has collected 100+ items on Envato Market
+4 more
bfintal
says

Yea but how about managing the data between them? re-input all contents to each and every one?

3439 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Achieved the monthly Community Superstar Award
  • Located in United States
+2 more
organicbee
says

either copy the database and change the url or use the export function

2067 posts
  • Has collected 50+ items on Envato Market
  • Has been part of the Envato Community for over 5 years
  • Sells items exclusively on Envato Market
  • Located in United States
Landonw
says

It only needs to be compatible with the latest, so isn’t this pointless?

101 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has been part of the Envato Community for over 4 years
  • Has referred 100+ members
  • Has sold $125,000+ on Envato Market
+2 more
PixelBook
says

It only needs to be compatible with the latest, so isn’t this pointless?

I agree

350 posts Gambit
  • Has been part of the Envato Community for over 5 years
  • Has referred 10+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has collected 100+ items on Envato Market
+4 more
bfintal
says

But how about the buyers who say for example bought the theme when it was WP 3 .0, then since there’s an update to the theme, re-downloads and updates the theme, but now WP 3 .0 is no longer supported since theres a WP 3 .1.2 now?

by
by
by
by
by
by