962 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+7 more
webdesigndeluxe
says

I’m making a website and for the life of me, cannot get the PNG ’s to work in IE6 . I’ve tried just about every solution out there. Here’s the issue, i’m setting PNG ’s as backgrounds of DIV ’s but I can’t think of any way to fix this in IE6 . I’ve tried everything and nothing is working! Please help!

415 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+4 more
osigrandi
says

i’ve done this before…setting transparent pngs as background. i used dd belated png fix.

do you have an online demo? i could take a look…

189 posts
  • Has referred 200+ members
  • Has sold $75,000+ on Envato Market and is now an Elite Author
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
+8 more
settysantu
says

use unit png fix, can u show preview

962 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+7 more
webdesigndeluxe
says
415 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+4 more
osigrandi
says

what solution do you use as a fix for the pngs? i can’t seem to find it?

edit: found it.

on the surface, there doesn’t seem to be anything wrong. first i thought it might have something to do with the way you preload the images…but the logo isn’t called from the preloading function and is affected as well.

mmm..unfortunately, at this point i’d recommend trying ddbelatedpng…i also tried unitpngfix and had problems with it…ddbelatedpng worked great.

962 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+7 more
webdesigndeluxe
says
what solution do you use as a fix for the pngs? i can’t seem to find it?

just re-uploaded it. It’s the Unit PNG Fix. ( a javascript file )

962 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+7 more
webdesigndeluxe
says
what solution do you use as a fix for the pngs? i can’t seem to find it?

edit: found it.

on the surface, there doesn’t seem to be anything wrong. first i thought it might have something to do with the way you preload the images…but the logo isn’t called from the preloading function and is affected as well.

mmm..unfortunately, at this point i’d recommend trying ddbelatedpng…i also tried unitpngfix and had problems with it…ddbelatedpng worked great.

Alright i’ll try it real quick. stay in touch, maybe I could use your help again :) Thanks!

415 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+4 more
osigrandi
says

np…i’ll stick around.not sleeping tonight anyway…

962 posts
  • Has been part of the Envato Community for over 6 years
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+7 more
webdesigndeluxe
says
np…i’ll stick around.not sleeping tonight anyway…

Thanks man. It still didn’t work. Something like this:

<!--[if lt IE 7]> <script type="text/javascript" src="js/ddbelated.js"></script> <![endif]-->

That’s all I did. What else do I need? Am I missing something?

2337 posts
  • Has referred 200+ members
  • Has sold $40,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Had an item that was trending
+7 more
CreativeMilk
says

The best way to fix this,just dont support IE6 ;)

by
by
by
by
by
by