962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says

I’m making a website and for the life of me, cannot get the PNG ’s to work in IE6 . I’ve tried just about every solution out there. Here’s the issue, i’m setting PNG ’s as backgrounds of DIV ’s but I can’t think of any way to fix this in IE6 . I’ve tried everything and nothing is working! Please help!

415 posts
  • Bought between 1 and 9 items
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
osigrandi says

i’ve done this before…setting transparent pngs as background. i used dd belated png fix.

do you have an online demo? i could take a look…

188 posts
  • Microlancer Beta Tester
  • India
  • Exclusive Author
  • Elite Author
  • Sold between 50 000 and 100 000 dollars
  • Has been a member for 5-6 years
  • Referred between 200 and 499 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+1 more
settysantu says

use unit png fix, can u show preview

962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says
415 posts
  • Bought between 1 and 9 items
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
osigrandi says

what solution do you use as a fix for the pngs? i can’t seem to find it?

edit: found it.

on the surface, there doesn’t seem to be anything wrong. first i thought it might have something to do with the way you preload the images…but the logo isn’t called from the preloading function and is affected as well.

mmm..unfortunately, at this point i’d recommend trying ddbelatedpng…i also tried unitpngfix and had problems with it…ddbelatedpng worked great.

962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says
what solution do you use as a fix for the pngs? i can’t seem to find it?

just re-uploaded it. It’s the Unit PNG Fix. ( a javascript file )

962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says
what solution do you use as a fix for the pngs? i can’t seem to find it?

edit: found it.

on the surface, there doesn’t seem to be anything wrong. first i thought it might have something to do with the way you preload the images…but the logo isn’t called from the preloading function and is affected as well.

mmm..unfortunately, at this point i’d recommend trying ddbelatedpng…i also tried unitpngfix and had problems with it…ddbelatedpng worked great.

Alright i’ll try it real quick. stay in touch, maybe I could use your help again :) Thanks!

415 posts
  • Bought between 1 and 9 items
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
osigrandi says

np…i’ll stick around.not sleeping tonight anyway…

962 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 1 000 and 5 000 dollars
  • United States
webdesigndeluxe says
np…i’ll stick around.not sleeping tonight anyway…

Thanks man. It still didn’t work. Something like this:

<!--[if lt IE 7]> <script type="text/javascript" src="js/ddbelated.js"></script> <![endif]-->

That’s all I did. What else do I need? Am I missing something?

2317 posts
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
  • Europe
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 100 and 199 users
+1 more
CreativeMilk says

The best way to fix this,just dont support IE6 ;)

by
by
by
by
by
by