8 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Netherlands
Jelte says

Hi,

I’m Jelte from Holland and i have a question. I have a strange problem with jQuery: all browsers accept and use my jQuery code correct, exept for all versions of IE.

I’ve included jQuery and my jQuery code like this: pastie

My jQuery code can be found here: code

The webdesign itself: website

It is not finished yet, so don’t judge that please. ;)

Anyone knows how to fix this? The html is valid, links are right… I really can’t think of any solution.

Regards, Jelte

8 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Netherlands
Jelte says

Whoops, sorry for the dubble post. I found the problem is this part of the jQuery:

//OPACITY ON BLOCKS
$('#contenttop .block').children('').animate({ "opacity" : 0.3 }, 0);
$('#contenttop .block').hover(function(){
    $(this).children('').stop().animate({
    "opacity" : 1,
    }, 100);
    $(this).css('cursor', 'pointer');
}, function(){
    $(this).children('*').stop().animate({
    "opacity" : 0.3
    });
});

When I comment that part out, the rest of the jQuery works well in IE. Maybe I’ll rewrite this part, i wasn’t happy with it after all. Or does somebody know a proper solution for this situation?

Jelte

322 posts
  • Bought between 100 and 499 items
  • Exclusive Author
  • Has been a member for 7-8 years
  • Referred between 10 and 49 users
  • Sold between 10 000 and 50 000 dollars
  • United States
  • Won a Competition
shadow66142000 says

First when debugging IE go into the settings and turn debugging on to receive your errors. But you have a comma that needs to be removed.
“opacity” : 1,
remove that comma and you should be all set. You will not see that error except in IE.

8 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Netherlands
Jelte says

@shadow: Thanks for that, it does work in IE now! Weird that a comma can turn the whole script down.

Didn’t know IE had a debugging mode… don’t use it very often. ;)

Thanks!

by
by
by
by
by
by