135 posts
  • Trendsetter
  • Author Level 6
  • Collector Level 2
  • Exclusive Author
+1 more
AccuraThemes
says

Is it necessary theme need to support IE 8.0

1882 posts
  • Affiliate Level 4
  • Author Level 9
  • Beta Tester
  • Collector Level 4
+7 more
Anps
says

Yes

248 posts
  • 4 Years of Membership
  • Affiliate Level 2
  • Author Level 5
  • Collector Level 1
+2 more
dmsumon
says

Is it necessary theme need to support IE 8.0

Yes because your item have to support all major versions of all major browsers. As IE8 is still the most used browser so your items have to support it.

1034 posts
  • Author Level 3
  • Beta Tester
  • Collector Level 1
  • Exclusive Author
+2 more
BenSheppard
says

Yes

392 posts
  • Most Wanted Winner
  • Author Level 13
  • Top Monthly Author
  • Trendsetter
+10 more
GoodLayers
says

I don’t think it’s a requirement but it’s good if your product supports it ;)

3804 posts
  • Elite Author
  • Author Level 11
  • Trendsetter
  • 7 Years of Membership
+12 more
KrownThemes
says

I don’t think it’s a requirement but it’s good if your product supports it ;)

it is..

490 posts
  • 4 Years of Membership
  • Affiliate Level 2
  • Author Level 7
  • Elite Author
+5 more
virtuti
says

I don’t think it’s a requirement but it’s good if your product supports it ;)

Hello, it is a requirement: http://themeforest.net/forums/thread/internet-explorer-8-compatibility-is-still-required/80910

At least that very post was published just 3 months ago…

Site must work properly in IE8. Although, it does not mean you must fight hard to get rounded corners, shadows, rgba and other CSS (decorative stuff) for IE8.

1565 posts
  • Affiliate Level 1
  • Author Level 5
  • Collector Level 2
  • Featured Author
+2 more
OriginalEXE
says

We are all hoping IE8 will die, but the sad truth is it will not go away very soon.

Even my parents use IE8 at home. I tried to sabotage them by installing Chrome but they did not want to use it :S

430 posts
  • 6 Years of Membership
  • Collector Level 4
  • Exclusive Author
  • United States
WPWiseOwl
says

These stats are encouraging – http://gs.statcounter.com/#browser_version-ww-monthly-201211-201301-bar

If you look at the “map” version instead of the bar chart, it would appear that China is the largest offender in this category with Iran second.

When jQuery 2.0 is released though and drops support for IE 6, 7, and 8, I’ll likely follow suit myself. Migration to v1.9 was the hardest part and v2.0 will be a breeze by comparison IMO.

516 posts
  • Super Copyright Ninja
  • Weekly Top Seller
  • Elite Author
  • Author Level 8
+8 more
Jaynesh
says

Try not to lose any hair on trying to make your theme look good in IE8. It doesn’t need to look good but it must be functional. :)

by
by
by
by
by
by