11 posts
  • 6 Years of Membership
  • Collector Level 2
  • United States
bopjo1
says

...because I am having problems with it. The Wordpress Creatif index page is not rendering correctly. There is a div named “block_content” that has no style rules at all or is even mentioned in the CSS file. I think that may be the problem as it wraps the main content area and sidebar, both of which are flush left in the browser, when they should be centered.

11 posts
  • 6 Years of Membership
  • Collector Level 2
  • United States
bopjo1
says

I have found an error in the code. In index.php there is this block of php:

<? if ($post->ID != $featured_ID) { ?>

On this line, the “php” is missing after the first question mark.

When the conditional ends, the authors have this code:

<? } ?>

Again, the “php” is missing after the question mark. This has nothing to do with my previous post, but is related to another error I was getting with the php code showing up in the browser in the post blocks.

It also caused the “featured post” to show up twice.

When I added the “php” after the question marks, the problem vanished and I no longer saw code on the page in the browser and the featured post only appeared once, where it should be at the top of the page.

I hope this helps someone else if they encounter the same problem.

1 post
  • 6 Years of Membership
  • Collector Level 2
vsul
says

Thanks so much, I have been trying to figure this issue out for over 2 hours now. Even the updated version of Rockstar wordpress does not update this error.

238 posts
  • 5 Years of Membership
  • Collector Level 1
  • Exclusive Author
ewizz
says

I have found an error in the code. In index.php there is this block of php:

<? if ($post->ID != $featured_ID) { ?>

On this line, the “php” is missing after the first question mark.

When the conditional ends, the authors have this code:

<? } ?>

Again, the “php” is missing after the question mark. This has nothing to do with my previous post, but is related to another error I was getting with the php code showing up in the browser in the post blocks.

It also caused the “featured post” to show up twice.

When I added the “php” after the question marks, the problem vanished and I no longer saw code on the page in the browser and the featured post only appeared once, where it should be at the top of the page.

I hope this helps someone else if they encounter the same problem.

<? was used in older versions of php, same as <?= and other thingies :P

353 posts
  • 6 Years of Membership
  • Collector Level 1
al_m473
says

I corrected that code in my copy as well, thanks

Al

3007 posts
  • 5 Years of Membership
  • Affiliate Level 5
  • Author Level 9
  • Bundle Boss
+8 more
duotive
says

:( this is one of the basic codding rejection reason for themes…... that is not a error. its just another practice that dose not work on all systems.

238 posts
  • 5 Years of Membership
  • Collector Level 1
  • Exclusive Author
ewizz
says

:( this is one of the basic codding rejection reason for themes…... that is not a error. its just another practice that dose not work on all systems.

it isn’t system related or practice, it depends on php settings (php.ini or other), you can enable module for short tag

1383 posts
  • 5 Years of Membership
  • Affiliate Level 2
  • Collector Level 2
  • Exclusive Author
+1 more
wpCanyonThemes
says


:( this is one of the basic codding rejection reason for themes…... that is not a error. its just another practice that dose not work on all systems.
it isn’t system related or practice, it depends on php settings (php.ini or other), you can enable module for short tag

Correct. I find them easier to use (less writing, especially the echo), but i use them only on client projects if they’re enabled, they shouldn’t be used on themes since you can’t know if the customer will have them enabled.

3007 posts
  • 5 Years of Membership
  • Affiliate Level 5
  • Author Level 9
  • Bundle Boss
+8 more
duotive
says

did not know about php.ini but i saw that in some systems this is not enabled…

by
by
by
by
by
by