1276 posts
  • Envato Staff
  • Reviewer
  • United Kingdom
  • Sold between 10 000 and 50 000 dollars
  • Won a Competition
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Gold Mo Grower
  • Author had a File in an Envato Bundle
  • Most Wanted Bounty Winner
+12 more
ChristineWilde Reviewer says

Hi everyone,

I’m trying to put a JavaScript slider on my home page in my Wordpress theme for ThemeForest. I’ve done everything the help file has said I need to do but it doesn’t seem to be working.

I’ve linked to the exact location of where the JavaScript files are but it just doesn’t seem to work. I’m so confused. I think it might be something to do with my local server…

Any help would be awesome!

1182 posts
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 1 and 9 users
campolar says

Xampp shouldn’t have anything to do with JS not working.

Just make sure the JS file links are correct. One short way is open the page in firefox. Right click and view the source. In the source, click the link of where the JS is located (the src in the script tag) and if it leads, its fine. If it doesn’t find it, its probably a wrong location.

1276 posts
  • Envato Staff
  • Reviewer
  • United Kingdom
  • Sold between 10 000 and 50 000 dollars
  • Won a Competition
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Gold Mo Grower
  • Author had a File in an Envato Bundle
  • Most Wanted Bounty Winner
+12 more
ChristineWilde Reviewer says
Xampp shouldn’t have anything to do with JS not working. Just make sure the JS file links are correct. One short way is open the page in firefox. Right click and view the source. In the source, click the link of where the JS is located (the src in the script tag) and if it leads, its fine. If it doesn’t find it, its probably a wrong location.

The link is fine though. I used firebug in FireFox to check the links in the header and they linked to the JS file. I’ll double check it again.

367 posts plop
  • Elite Author
  • Sold between 50 000 and 100 000 dollars
  • Beta Tester
  • Has been a member for 5-6 years
  • Grew a moustache for the Envato Movember competition
  • Referred between 50 and 99 users
  • Interviewed on the Envato Notes blog
+3 more
kimonoThemes says

Which Slider are you using?

5 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Indonesia
dierka says

Do you use FF plugin like WebDev tools or turn on FireBug console? It could help a little if anything seems goes wrong in the script that make it did not working.

1276 posts
  • Envato Staff
  • Reviewer
  • United Kingdom
  • Sold between 10 000 and 50 000 dollars
  • Won a Competition
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Gold Mo Grower
  • Author had a File in an Envato Bundle
  • Most Wanted Bounty Winner
+12 more
ChristineWilde Reviewer says

I’m using this slider: LINK

I have FireBug installed on FireFox.

367 posts plop
  • Elite Author
  • Sold between 50 000 and 100 000 dollars
  • Beta Tester
  • Has been a member for 5-6 years
  • Grew a moustache for the Envato Movember competition
  • Referred between 50 and 99 users
  • Interviewed on the Envato Notes blog
+3 more
kimonoThemes says

Try to get it work on a single page… and then include it into your WordPress.

397 posts
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
  • Sold between 10 000 and 50 000 dollars
Monkify says

it’s most likely your path to your javascript files is wrong, other then that if you include the JS through Wordpress, you need to use the jQuery(’..’) tag instead of the $(’...’)-tag

1276 posts
  • Envato Staff
  • Reviewer
  • United Kingdom
  • Sold between 10 000 and 50 000 dollars
  • Won a Competition
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Gold Mo Grower
  • Author had a File in an Envato Bundle
  • Most Wanted Bounty Winner
+12 more
ChristineWilde Reviewer says

OK I ’ll check it over again. I’ve been working on this theme for over a month now and have decided to get everything working this week so I can start on the documentation this weekend.

by
by
by
by
by
by