224 posts
  • Sold between 10 000 and 50 000 dollars
  • Author had a File in an Envato Bundle
  • Referred between 1 and 9 users
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
  • Argentina
  • Exclusive Author
WPAlchemy says

For the last few days i have been having several javascript problems within the Envato sites… For example the hidden ‘reply’ buttons on the comments section not appearing, the ‘single license / extended license’ accordion not working and stuff like that. It nothing I cant fix with the element inspector but it gets quite annoying.

Am i the only one with this problem or anyone else gets this too?

939 posts
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Envato Studio (Microlancer) Beta Tester
  • Serbia
  • Exclusive Author
aleluja says

They are working on the front-end. Things like that can occur.

7177 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 10 000 and 50 000 dollars
  • Envato Studio (Microlancer) Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Author had a Free File of the Month
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
+1 more
doru says

Did you installed addons that blocks certain functionality on web, like noscript or ghostery?

224 posts
  • Sold between 10 000 and 50 000 dollars
  • Author had a File in an Envato Bundle
  • Referred between 1 and 9 users
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
  • Argentina
  • Exclusive Author
WPAlchemy says

Nope, only new addon I have is tampermonkey to run revaxarts’ script,. I disabled it anyways when this started happening and nothing changed.

91 posts
  • Envato Developer
  • Has been a member for 3-4 years
  • Envato Staff
  • Australia
  • Bought between 1 and 9 items
bensmithett Dev says

Hey WPAlchemy,

We’ve tried reproducing the issues you mentioned with no luck. If you keep having problems could you please open a support ticket (note your browser version, OS, add-ons etc) and we’ll look into it.


They are working on the front-end. Things like that can occur.

That’s what you have a sandbox dev environment for… so these types of issues do not occur once pushed to the live environment. If anything, push the live environment to a small portion of end users and collect data on those end users before pushing live to the entire community.

We’re very serious about automated + manual testing & small betas before we ship so we can be as sure as possible that issues like this won’t occur :)

594 posts
  • Author had a File in an Envato Bundle
  • Envato Studio (Microlancer) Beta Tester
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Sold between 10 000 and 50 000 dollars
designcise says

I’ve been having these issues since ages and I’ve reported similar issues too: here, here and here. It’s probably because the scripts are being loaded on-demand which makes features like the “reply” button, “more information” link on the ratings, “sort by” filter etc. unusable for a few seconds.

@bensmithett .. you’re probably not seeing these issues because you might be on a fast internet connection comparatively. try it on a bit slower internet; i get about 200-300 kbs download speed. hope that helps.

91 posts
  • Envato Developer
  • Has been a member for 3-4 years
  • Envato Staff
  • Australia
  • Bought between 1 and 9 items
bensmithett Dev says

@designcise you’re right, in some areas we could improve the way we handle UI state in the time between rendering & JS being ready. We often progressively enhance so, for example, a user who interacts before the JS has loaded simply gets a full page load rather than ajax. But I’ll look into the specific issues you mentioned. Thanks :)

7177 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 10 000 and 50 000 dollars
  • Envato Studio (Microlancer) Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Author had a Free File of the Month
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
+1 more
doru says

forgot (since was just one time ) but happened to me two days ago to not see the reply button when trying to answer a comment on my item from my dashboard. Don’t know if is related.

939 posts
  • Sold between 1 000 and 5 000 dollars
  • Most Wanted Bounty Winner
  • Has been a member for 5-6 years
  • Referred between 1 and 9 users
  • Envato Studio (Microlancer) Beta Tester
  • Serbia
  • Exclusive Author
aleluja says


They are working on the front-end. Things like that can occur.
That’s what you have a sandbox dev environment for… so these types of issues do not occur once pushed to the live environment. If anything, push the live environment to a small portion of end users and collect data on those end users before pushing live to the entire community.

I agree but, hey, people make mistakes.

by
by
by
by
by
by