183 posts
  • 7 Years of Membership
  • Affiliate Level 2
  • Author Level 5
  • Beta Tester
+5 more
tomez
says

Good news. :)

Are you sitting down? Well sit down, in front of your computer, and start downloading. We have several new jQuery releases for you to test. For your convenience, jQuery can even be downloaded while standing.
http://blog.jquery.com/2013/01/15/jquery-1-9-final-jquery-2-0-beta-migrate-final-released/
63 posts
  • Collector Level 1
  • Italy
  • 2 Years of Membership
Kronris
says

Very good news! :)
Thanks for sharing! :)

3804 posts
  • Elite Author
  • Author Level 11
  • Trendsetter
  • 7 Years of Membership
+12 more
KrownThemes
says

1. Go through your entire portfolio’s scripts and delete every occurrence of $.browser, otherwise you’ll have broken themes..

2. Actually .. stop using jQuery anymore since 2.0 doesn’t support IE8..

YaY! Very good news! It’s good that i was sitting down :D

683 posts
  • 4 Years of Membership
  • Author Level 5
  • Collector Level 2
  • Exclusive Author
ChapterThemes
says

Jquery that doesn’t support IE8 ? That’s kind of strange…. the whole power of jQuery is ( or was ) that it almost worked in every browser even explorer 7 or so…

Do you know the reason of this?

683 posts
  • 4 Years of Membership
  • Author Level 5
  • Collector Level 2
  • Exclusive Author
ChapterThemes
says

“The team is supporting both jQuery 1.9 and 2.0 into the future. You choose which version you want to use based on your needs.”

Seems like there will be 2 maintained versions as 1.9 keeps supporting oldIE and 2.0 does not…

815 posts
  • Affiliate Level 1
  • Author Level 5
  • Collector Level 1
  • Freebie
+3 more
rvision_
says

Jquery that doesn’t support IE8 ? That’s kind of strange…. the whole power of jQuery is ( or was ) that it almost worked in every browser even explorer 7 or so… Do you know the reason of this?

Good decision. Another nail in the IE coffin.

510 posts Ngoc Viet
  • Affiliate Level 3
  • Author Level 7
  • Collector Level 3
  • Elite Author
+3 more
wopethemes
says

ie8 is the last browser that don’t support css3 and html5. I guess it’s a main reasons

3804 posts
  • Elite Author
  • Author Level 11
  • Trendsetter
  • 7 Years of Membership
+12 more
KrownThemes
says

Seems like there will be 2 maintained versions as 1.9 keeps supporting oldIE and 2.0 does not…

Yes i knew.. I just wanted to be more dramatic about it :|

2468 posts
  • 6 Years of Membership
  • Author Level 2
  • Affiliate Level 4
  • Beta Tester
+3 more
digitalimpact
says

“The team is supporting both jQuery 1.9 and 2.0 into the future. You choose which version you want to use based on your needs.” Seems like there will be 2 maintained versions as 1.9 keeps supporting oldIE and 2.0 does not…

If you develop WordPress themes for distribution, you don’t get to choose, unfortunately. You need to use the jQuery version provided by WordPress. And if that will get to be 2.0… well… bring it! :D

3439 posts
  • Author Level 4
  • Collector Level 2
  • Community Superstar
  • United States
+2 more
organicbee
says

So everyone know 1.9 will be in WordPress 3.6, its already in alpha, they may upgrade it to 2 but Im not sure theyll make that step

by
by
by
by
by
by