501 posts
  • Has referred 1000+ members
  • Has sold $500,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Became a Top 20 Author of the Month
+10 more
pixelentity
says

We stumbled upon this while testing a simple CSS scale transition for a new item: worked as expected with all major browsers but epic fail with Firefox. (image jumping to another position)

After a medium-to-long wtf-ing session, we were able to create a test case on jsfiddle and conclude this is a browser bug, here’s the test link:

http://jsfiddle.net/jQ3fs/10/

Please check and post here if the bug is happening for you as well + your Firefox version as we’d like to file a bug report with Mozilla for this issue.

11 posts
  • Has been part of the Envato Community for over 3 years
  • Has sold $100+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
jpdr
says

Yes, looks like a bug, I’m with win7 and firefox 10.0.2

2277 posts
  • Became a Top 20 Author of the Month
  • Had an item that became a weekly top seller
  • Created a helpful tool/app using the Envato API
  • Created a helpful tool/app for Envato Market users
+15 more
revaxarts
says

same here win7, firefox 10.0.2

156 posts
  • Became a Top 20 Author of the Month
  • Had an item that was trending
  • Had an item that became a weekly top seller
  • Power Elite Author: Sold more than $1M on Envato Market
+8 more
Semenov
says

Same thing on OS X , 10.0.2

It seems that it starts working properly when you add background to img element. Or by changing scale on hover a bit – scale(0.80001).

286 posts
  • Helped protect Envato Market against copyright violations
  • Became a Top 20 Author of the Month
  • Had an item that was trending
  • Had an item that became a weekly top seller
+12 more
nickys
says

Looks like a bug, yes. I found one in Firefox myself while developing an item, it triggers the transitions on mouse over, while they should only be triggered on :target.

3757 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Located in Spain
  • Has sold $125,000+ on Envato Market
  • Made it to the Authors' Hall of Fame
+11 more
pezflash
says

Same for me, W7 – FF 10 .0.2

I also found one bug in FF yesterday. When i refresh the page (F5) it always displays the same income on top right. No increment at all.

992 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $250,000+ on Envato Market
  • Became a Top 20 Author of the Month
  • Had an item that was trending
+9 more
LCweb
says

same here win7, firefox 10.0.2

idem, +1

501 posts
  • Has referred 1000+ members
  • Has sold $500,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Became a Top 20 Author of the Month
+10 more
pixelentity
says

It seems that it starts working properly when you add background to img element
yep, found out the same workaround

background-color: rgba(255,255,255,.01);
seems to work http://jsfiddle.net/jQ3fs/27/

edit:
adding a border seems to fix as well

501 posts
  • Has referred 1000+ members
  • Has sold $500,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Became a Top 20 Author of the Month
+10 more
pixelentity
says

I also found one bug in FF yesterday. When i refresh the page (F5) it always displays the same income on top right. No increment at all.
mmm … i suspect that to be a crossbrowser bug :P

BF

1688 posts Envato Elite Author
  • Has referred 10+ members
  • Has sold $125,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Became a Top 20 Author of the Month
+8 more
Tean
says


I also found one bug in FF yesterday. When i refresh the page (F5) it always displays the same income on top right. No increment at all.
mmm … i suspect that to be a crossbrowser bug :P BF

Nope, only in browsers that dont support html5 :D

by
by
by
by
by
by