4 posts
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
tyanta says

Hello everyone,

I purchased “Album Memories” for my wedding that’s a week away. I’ve tried contacting the author with no reply so I’m turning here for help.

Everything works great so this is more of a general AE question.

I’m trying to extend it on my own. I’ve added the necessary media placeholders, I’ve extended the main comp and to add pages, I thought it would be easiest to either copy or duplicate existing pages, so I did just that. I duplicated the last four pages then renamed them. Well each page comp has photo and video comps embedded in each. You essentially drill down to where you find where the media goes. Great, I replaced the existing media with the newly created piece and rename every comp within the page. I noticed that even the parent assets auto-renamed accordingly. Great, I thought.

But when I look at the composition flow chart, it’s still referencing the comps from the original page, which is a problem! If I make a change on my new page, it changes my old one.

So that’s where I’m stuck. Some guidance would be much appreciated! Planning a wedding is stressful enough without finding yourself up against a brick wall :)

727 posts
  • Sold between 10 000 and 50 000 dollars
  • Exclusive Author
  • Envato Studio (Microlancer) Beta Tester
  • Has been a member for 2-3 years
  • Referred between 1 and 9 users
  • Bought between 1 and 9 items
  • United States
GrizzleFX says

A very annoying yet helpful feature of AE. There is a script that helps with this problem, i’ll link you to it below. Without this script you have to basically copy everything within precomps re-precomp it and repeat which is very time consuming. This script allows you to do that with the click of a button. It’s also “name your own price” so if you can get it for free.

TrueCompDuplicator
4 posts
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
tyanta says

THANK YOU !!!

This is exactly what I was looking for. I just tested it out and with a smidge of tweaking this will work perfectly. I went to sleep last night thinking I’d have to do as you suggested – copy everything over manually. I can breathe again :)

4 posts
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
tyanta says

Last hurdle:

Camera control. So using the script above, I duplicated the pre-comps and added them to the comp timeline. I noticed everything was working except the camera motion. I saw the camera control layer and copied the keyframes from the 4 pages I duplicated and pasted them above the duplicated layers.

Now when I scrub through the project, it plays fine panning and zooming until I hit my duplicated portion. Then the view stays fixed and a red square representing the camera movement follows the the keyframes. It’s like the camera isn’t associated with the keyframes I copied.

What step did I miss?

Again, appreciate the help for such n00b questions!

4 posts
  • Bought between 1 and 9 items
  • Has been a member for 1-2 years
tyanta says

Enabling 3D layer helps :bashful:

by
by
by
by
by
by