335 posts Andre28 - Envato Elite Author
  • Has referred 1000+ members
  • Has sold $125,000+ on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
  • Made it to the Authors' Hall of Fame
+4 more
andre28 says

When someone write to me though my profile page, the email always go under the “spam” section on my provider email… Is there anything i can do to fix this? I always click on the “this message is safe” button, but nothing change… Any suggestions?? Thank you

17 posts
  • Has been part of the Envato Community for over 3 years
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has collected 50+ items on Envato Market
+4 more
beatlover says

Check your spam settings in your email account… You can add filter eq. if message subject contains [GraphicRiver] mark this as not spam :)

1253 posts
  • Has referred 10+ members
  • Has sold $40,000+ on Envato Market
  • Has collected 100+ items on Envato Market
  • Sells items exclusively on Envato Market
+2 more
Demorfoza says

Are you using a web based mail, or software to check your mailbox?

335 posts Andre28 - Envato Elite Author
  • Has referred 1000+ members
  • Has sold $125,000+ on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
  • Made it to the Authors' Hall of Fame
+4 more
andre28 says

i’m using windows live mail, with my account on hotmail… still i haven’t solved this problem..

11 posts
  • Has been part of the Envato Community for over 3 years
  • Has collected 10+ items on Envato Market
  • Located in United States
spoocobra says

I’d switch that to gmail and do like beatlover says and add filters.

by
by
by
by
by
by