595 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 10+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
+5 more
designcise says

Hi, I’m working on an update to my “assign” script and have been running into some issues while testing and I wanted to know if it’s just on my computer or if everyone else gets the same issue (in that case, it would be beyond my control of course).

Can you guys spare a few minutes and run these tests for me and post the answer here.

Thank you!

1460 posts
  • Has been part of the Envato Community for over 4 years
  • Had an item featured in an Envato Pack
  • Has sold $1,000+ on Envato Market
  • Located in United States
+3 more
WebSmacker says

83 67 using Chrome

595 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 10+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
+5 more
designcise says

thanks .. did you press/hold them one by one .. like first holding down ‘d’ then ‘e’ (whilst d is still pressed) and then ’s’ (while both d and e are pressed)?

it’s interesting if you got 83 and 67 .. because i tried it on two of my computers and on all major browsers, couldn’t get 83 or 67 .. hmmph ..

443 posts
  • Has been part of the Envato Community for over 4 years
  • Has sold $1,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
SplitV says

Nothing at all in Firefox 8(win7)..

69 and 67 in Chrome 15 & IE 8

1460 posts
  • Has been part of the Envato Community for over 4 years
  • Had an item featured in an Envato Pack
  • Has sold $1,000+ on Envato Market
  • Located in United States
+3 more
WebSmacker says
designcise said
thanks .. did you press/hold them one by one .. like first holding down ‘d’ then ‘e’ (whilst d is still pressed) and then ’s’ (while both d and e are pressed)? it’s interesting if you got 83 and 67 .. because i tried it on two of my computers and on all major browsers, couldn’t get 83 or 67 .. hmmph ..

Yes, I did just the way you described and got the same results

108 posts
  • Has been part of the Envato Community for over 4 years
  • Located in Australia
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
Australiaa says

Nothing changes in FF

Test 1: chrome = 83

Test 2:chrome = 67

Looking at the test, you are fetching the keycode value last pressed for s which is 83

also see: http://www.cambiaresearch.com/articles/15/javascript-char-codes-key-codes

595 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 10+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
+5 more
designcise says
Australia said
Nothing changes in FF

Test 1: chrome = 83

Test 2:chrome = 67

Looking at the test, you are fetching the keycode value last pressed for s which is 83

also see: http://www.cambiaresearch.com/articles/15/javascript-char-codes-key-codes

i know the keycodes, the problem is that the results everyone are getting are quite different and aren’t quite conclusive to draw any conclusions. so far the problem is that using some key combos such as “d+e+s” the last key is ignored. this is usually the case, i’ve observed when the keys you’re holding are too close together or could be some issue with how the operating system deals with this (can’t be an issue with the browsers because all of them give the same result, and can’t be an issue with the javascript libraries either as mootools gives the same result—could, however, be some issue with javascript handling keyboard key combos poorly maybe).

thank you everyone for helping me out, i might need a few more people to test it out before i can make any conclusions.

27 posts
  • Located in Germany
  • Made it to the Authors' Hall of Fame
  • Sells items exclusively on Envato Market
  • Has sold $10,000+ on Envato Market
+4 more
jdpowered says

Win7, IE9 : 83 and 67

Win7, Firefox 8: the 0 does not change but the search bar opens instead with “des” and “DC” entered

1460 posts
  • Has been part of the Envato Community for over 4 years
  • Had an item featured in an Envato Pack
  • Has sold $1,000+ on Envato Market
  • Located in United States
+3 more
WebSmacker says

Ok, I might have some insight for you. Last night I tested with Chrome on Windows 7 64-bit machine and got 83, 67. Today I tested with Chrome on Windows XP 32 -bit machine and got 69, 67. It very well could be based on OS version.

595 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 10+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
+5 more
designcise says

thank you everyone..

@iapcsolutions .. that is very strange ..

to rule it out as an OS-related problem I need someone to check this on a Mac and/or Linux (a big thank you in advance!) .. that should give sufficient proof that it’s indeed an OS issue ..

but if it’s not, anyone got any idea what could be causing this issue? and why is it that keys which are right next to, or above or underneath, each other are the only ones creating this problem (that too, usually when three keys are being held) ..

by
by
by
by
by
by