138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says

Hey guys,

I need help with a page navi problem on my site. When you click on the page links at the bottom it redirects you to the page id but not the actual page.

So if you click on example.com/page/2 it redirects you to example.com/29 (29 happens to be the page id) and shows a 404 error.

Anyone know how to fix it?

I’ve disabled all plugins, tried creating a new .htacess file, different permalink structures, etc.

The site is premiumthemes.tv

Thanks for your help! :)

3007 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has sold $250,000+ on Envato Market
  • Had an item featured in an Envato Bundle
+7 more
duotive says

Leave the permaink structure to the default one and see what happens!

138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says
duotive said
Leave the permaink structure to the default one and see what happens!

Thanks for the reply :) Change it to default and nothing changed, had to delete cache plugin and then it worked.

When I change it back to what I have been using / postname / it doesn’t work anymore.

I noticed the navigation links are ?paged=2 so maybe that’s what causing the error since / postname / changes it to /page/2/.

What puzzles me though is that it worked before so not sure why it wouldn’t work now…

138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says

Not sure why, but when I’m logged in as admin the links work…

3007 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has sold $250,000+ on Envato Market
  • Had an item featured in an Envato Bundle
+7 more
duotive says
WPHead said
Not sure why, but when I’m logged in as admin the links work…

Because when you are logged in the cache dose not apply. Disable the cache and the links will work. You need to follow a guide on how to properly setup the cache plugin.

138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says
duotive said
WPHead said
Not sure why, but when I’m logged in as admin the links work…
Because when you are logged in the cache dose not apply. Disable the cache and the links will work. You need to follow a guide on how to properly setup the cache plugin.

Yes, I know and i’ve disabled the cache plugin (removed all files) to see if it works but it doesn’t. The plugin is set up exactly as on my other sites were it works without a problem.

3007 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has sold $250,000+ on Envato Market
  • Had an item featured in an Envato Bundle
+7 more
duotive says
WPHead said
duotive said
WPHead said
Not sure why, but when I’m logged in as admin the links work…
Because when you are logged in the cache dose not apply. Disable the cache and the links will work. You need to follow a guide on how to properly setup the cache plugin.
Yes, I know and i’ve disabled the cache plugin (removed all files) to see if it works but it doesn’t. The plugin is set up exactly as on my other sites were it works without a problem.

What is your permalink structure?

138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says
duotive said
WPHead said
duotive said
WPHead said
Not sure why, but when I’m logged in as admin the links work…
Because when you are logged in the cache dose not apply. Disable the cache and the links will work. You need to follow a guide on how to properly setup the cache plugin.
Yes, I know and i’ve disabled the cache plugin (removed all files) to see if it works but it doesn’t. The plugin is set up exactly as on my other sites were it works without a problem.
What is your permalink structure?

/ % postname % / (without spaces)

138 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 200+ members
  • Has collected 50+ items on Envato Market
  • Sells items exclusively on Envato Market
WPHead says

The “Disable Canonical URL Redirection” plugin fixes the problem.

Thanks duotive for taking the time and try to help, I appreciate it :)

Edit: http://txfx.net/files/wordpress/disable-canonical-redirects.phps

Helpful Information

  • Please read our community guidelines. Self promotion and discussion of piracy is not allowed.
  • Open a support ticket if you would like specific help with your account, deposits or purchases.
  • Item Support by authors is optional and may vary. Please see the Support tab on each item page.

Most of all, enjoy your time here. Thank you for being a valued Envato community member.

Post Reply

Format your entry with some basic HTML. Read the Full Details, or here is a refresher:

<strong></strong> to make things bold
<em></em> to emphasize
<ul><li> or <ol><li> to make lists
<h3> or <h4> to make headings
<pre></pre> for code blocks
<code></code> for a few words of code
<a></a> for links
<img> to paste in an image (it'll need to be hosted somewhere else though)
<blockquote></blockquote> to quote somebody

:grin: :shocked: :cry: Complete List of Smiley Codes

by
by
by
by
by
by