426 posts Keep Walking
  • Has been part of the Envato Community for over 3 years
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Has collected 100+ items on Envato Market
+2 more
UXbarn says

Hi did anybody tested OptionTree with the latest WordPress 3.5 beta 2? It seems that there are some problems with “select” in forms – it’s not displaying correctly. I’m curious is it only in my theme or by default ;)

Hi purethemes,

I just tested my theme with WP 3.5 and I’m having the display issue of “select” in forms too. They didn’t show up and there’s JavaScript error as:

http://postimage.org/image/q4jfidxdp/full/

I think I have registered OptionTree properly as the instruction said but, in this case, I just have no idea what’s wrong with it. It used to be fine in WP 3.4.2. :S

Could you please share a solution? Or do you have any idea which part I have to modify to get rid of this problem?

Thank you. :)

332 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
+3 more
dekciw says


Hi did anybody tested OptionTree with the latest WordPress 3.5 beta 2? It seems that there are some problems with “select” in forms – it’s not displaying correctly. I’m curious is it only in my theme or by default ;)

Hi purethemes,

I just tested my theme with WP 3.5 and I’m having the display issue of “select” in forms too. They didn’t show up and there’s JavaScript error as:

http://postimage.org/image/q4jfidxdp/full/

I think I have registered OptionTree properly as the instruction said but, in this case, I just have no idea what’s wrong with it. It used to be fine in WP 3.4.2. :S

Could you please share a solution? Or do you have any idea which part I have to modify to get rid of this problem?

Thank you. :)

Got exactly the same issue. :(

If anyone come up with a solution – please share.

332 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
+3 more
dekciw says

Ok, it seems I’ve found an culprit. Gonna test that out and report back.

EDIT:

UXbarn, just update OptionTree to newest version. :)

I had the same issue with a theme, which had some older version of OptionTree integrated. assets/js/ot-admin.js @ line 366 there’s a selector ’.select-wrapper.’ (with the dot in the end) which causes the problem. Removing that dot fixed it. But as I’ve said – just update your OptionTree and you should be good to go – this is fixed in newer version (just check that).

426 posts Keep Walking
  • Has been part of the Envato Community for over 3 years
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Has collected 100+ items on Envato Market
+2 more
UXbarn says

That works perfectly! Thank you so much dekciw! :bigsmile:

3576 posts Ruben Bristian
  • Sells items exclusively on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $500,000+ on Envato Market
  • Has been part of the Envato Community for over 6 years
+10 more
KrownThemes says

There’s also another issue, making infinite errors in the console. In /assets/js/ot-admin.js, line 294 should become:

if ( $('#TB_iframeContent').attr('src') != 'undefined' && $('#TB_iframeContent').attr('src').indexOf( "&field_id=" ) !== -1 )
1359 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Made it to the Authors' Hall of Fame
  • Has been part of the Envato Community for over 5 years
  • Has sold $250,000+ on Envato Market
+6 more
fuelthemes says

I had no problems with the newest version and WP 3.5

168 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Has been part of the Envato Community for over 3 years
  • Located in Europe
+1 more
Decneo says

I think It’s fixed now in new version.

438 posts
  • Has been part of the Envato Community for over 2 years
  • Has sold $5,000+ on Envato Market
  • Has collected 50+ items on Envato Market
  • Located in Europe
+1 more
Pixelous says

Hi valendesigns!

I have a problem. Some of the buyers have empty theme options when they installed the theme! The only solution I have found is to re-install WordPress with completely new database. But now I have the buyer that already re-installed the WordPress in a new date base to check if he could fix the problem but it still happening.

valendesigns can you please help?

P. S. Anyone have something similar?

1 post
MarinSto says

I found that too. Is there a solution?

Marin Stoyanov

196 posts
  • Has been part of the Envato Community for over 4 years
  • Has referred 10+ members
  • Has sold $10,000+ on Envato Market
  • Sells items exclusively on Envato Market
+1 more
ki-themes says

I found that too. Is there a solution? Marin Stoyanov

MArin, I could help you if you can drop me an email via contact form.

by
by
by
by
by
by