168 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Has been part of the Envato Community for over 3 years
  • Located in Europe
+1 more
Decneo says

Hi, pagination not work correctly on hosting but work fine on localhost?

Best regards, Decneo

320 posts
  • Has been part of the Envato Community for over 2 years
  • Sells items exclusively on Envato Market
  • Has sold $40,000+ on Envato Market
  • Won a Most Wanted contest
+4 more
SuggeElson says

Be more specific. Pagination on what ? :))

168 posts
  • Has sold $10,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Has been part of the Envato Community for over 3 years
  • Located in Europe
+1 more
Decneo says

Be more specific. Pagination on what ? :))

Pagination on the bog overview.

Best regards, Decneo

1148 posts
  • Has referred 1+ members
  • Has sold $1,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 10+ items on Envato Market
+3 more
fillerspace says

Pagination not working how? No pagination shows up? Or the links are pointing to the wrong place? Are the number out of order? You have to give more details.

53 posts Jegtheme
  • Elite Author: Sold more than $75,000 on Envato Market
  • Sells items exclusively on Envato Market
  • Has sold $125,000+ on Envato Market
  • Has referred 100+ members
+4 more
jegtheme says

get 404 page? you create new page template that will override blog in reading section?

5 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in United Kingdom
QuantumConcepts says

get 404 page? you create new page template that will override blog in reading section?

Hi Jegtheme,

I’m also experiencing this issue on my portfolio page. When I select page 2 of the pagination, I get the 404 error page. Thanks very much for posting a solution to this issue but I don’t fully understand what you mean.

If you don’t mind, would you please post step by step instructions?

Thanks in advance.

3247 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says


get 404 page? you create new page template that will override blog in reading section?

Hi Jegtheme,

I’m also experiencing this issue on my portfolio page. When I select page 2 of the pagination, I get the 404 error page. Thanks very much for posting a solution to this issue but I don’t fully understand what you mean.

If you don’t mind, would you please post step by step instructions?

Thanks in advance.

flush your permalinks(aka go re-save them in the WordPress admin)

5 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in United Kingdom
QuantumConcepts says

flush your permalinks(aka go re-save them in the WordPress admin)

Hi OrganicBeeMedia,

Thanks for your suggestion. I tried it but it didn’t work. I also tried adding this code to my functions.php file;

<?php add_action(‘admin_init’, ‘flush_rewrite_rules’); ?>

This didn’t work either.

5 posts
  • Has been part of the Envato Community for over 2 years
  • Has collected 1+ items on Envato Market
  • Located in United Kingdom
QuantumConcepts says

I’ve also created a custom taxonomy file called taxonomy.php with the following code;

<?php add_action(‘init’, ‘create_custom_taxonomy’); function create_custom_taxonomy (){ register_taxonomy(portfolio, ‘post’, array( ‘hierarchical’ => false, ‘label’ => ‘Portfolio’, ‘query_var’ => portfolio, ‘rewrite’ => array(‘slug’=>portfolio) ) ); } ?>

I then added the following code to my functions.php file;

<?php add_action(‘init’, ‘custom_taxonomy_flush_rewrite’); function custom_taxonomy_flush_rewrite() { global $wp_rewrite; $wp_rewrite->flush_rules(); } ?>

This doesn’t work either.

24 posts
  • Has been part of the Envato Community for over 2 years
Theme-Titans says

I also had the same issue as this awhile back while i was working on a theme i dunno maybe its a wordpress bug or something, make sure you go to Settings<Reading and change this “Blog pages show at most” make sure its the same number as with your post per page in your wordpress query.

query_posts( ‘posts_per_page=10’ );

Hope this helps.

by
by
by
by
by
by