5 posts
    Has been part of the Envato Community for over 2 years Has collected 1+ items on Envato Market Located in United Kingdom
QuantumConcepts says

I also had the same issue as this awhile back while i was working on a theme i dunno maybe its a wordpress bug or something, make sure you go to Settings<Reading and change this “Blog pages show at most” make sure its the same number as with your post per page in your wordpress query.

query_posts( ‘posts_per_page=10’ );

Hope this helps.

Hi Theme-Titans,

Thanks for your suggestion. Both of my values are set to 8 so unfortunately this didn’t help.

51 posts Jegtheme
    Has referred 100+ members Has sold $125,000+ on Envato Market Has been a beta tester for an Envato feature Has collected 10+ items on Envato Market
+4 more
jegtheme says

btw where is 404 page appear? on custom post or default blog post?

if you mean on default blog post you can try this : 1. on setting > reading > Posts page, don’t check anything. 2. setting > permalink, change it to post name. or try change until you get the right result.

167 posts
    Has sold $10,000+ on Envato Market Has collected 10+ items on Envato Market Has been part of the Envato Community for over 3 years Located in Europe
+1 more
Decneo says

the paginate is appear but the link is link to page 404!!! :(

also it’s default blog post.

Best regards, Decneo

167 posts
    Has sold $10,000+ on Envato Market Has collected 10+ items on Envato Market Has been part of the Envato Community for over 3 years Located in Europe
+1 more
Decneo says

btw where is 404 page appear? on custom post or default blog post? if you mean on default blog post you can try this : 1. on setting > reading > Posts page, don’t check anything. 2. setting > permalink, change it to post name. or try change until you get the right result.

I will try this then will let you know.

thanks, Decneo

60 posts Talk less do more!
    Has referred 10+ members Has sold $75,000+ on Envato Market and is now an Elite Author Has collected 50+ items on Envato Market Elite Author: Sold more than $75,000 on Envato Market
+3 more
Rifki says


get 404 page? you create new page template that will override blog in reading section?

Hi Jegtheme,

I’m also experiencing this issue on my portfolio page. When I select page 2 of the pagination, I get the 404 error page. Thanks very much for posting a solution to this issue but I don’t fully understand what you mean.

If you don’t mind, would you please post step by step instructions?

Thanks in advance.

I guess that you’re using the slug that same with the parent page slug, if you’re using “portfolio” for the custom post type slug you shouldn’t using “portfolio” for the Portfolio page, try with “portfolios”.

Rifki

5 posts
    Has been part of the Envato Community for over 2 years Has collected 1+ items on Envato Market Located in United Kingdom
QuantumConcepts says

I guess that you’re using the slug that same with the parent page slug, if you’re using “portfolio” for the custom post type slug you shouldn’t using “portfolio” for the Portfolio page, try with “portfolios”.

Rifki

Thank you so much! You were absolutely right. Basically, WordPress won’t allow you to have a page and a custom post type of the same name. I had a page called portfolio, which is also the name of the custom post type. I changed the page name to “Our Portfolio” and now the pagination works.

by
by
by
by
by
by