4 posts
  • Has been part of the Envato Community for over 1 year
  • Has collected 1+ items on Envato Market
two_larsens says

Hello, I am trying to make a rather basic website, but having purchased the Pacifico theme, I ran into the issue of the images not showing up (I’m new to this). So, I went back and read I had to set the permissions to ‘777’ for certain folders within the FTP client, which I then did. However, it also said to create a folder, and I quote:

“And also you’ll have to create a new folder with “777” settings:

/wp-content/uploads

You can do it via your FTP client. Open a drop-down menu by clicking the right mouse on one of the folders, specified above. Choose there “access rights” (or maybe something similar) and make changes. Also apply this for the subfolders and nested files.

What does that mean, and what do I name the folder? There is one under Uploads, where the directory tree goes – Uploads, 2013, and then a folder called ‘03’, in which the images I uploaded , and that are not showing as of yet, are stored.

Any help is greatly appreciated.

Thanks,

HL

3228 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says

Never ever make a folder with the permissions 777 period, thats a gigantic security risk

http://codex.wordpress.org/Changing_File_Permissions#The_dangers_of_777
4 posts
  • Has been part of the Envato Community for over 1 year
  • Has collected 1+ items on Envato Market
two_larsens says

Thanks. What do I do, then?

3228 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says

Thanks. What do I do, then?

You should be able to use a different permission thats secure, but without knowing why the authors wants you to set a permission to 777 I cant tell you which to use.

I’m assuming its for a image script(like timthumb) and you probably could use 755.

4 posts
  • Has been part of the Envato Community for over 1 year
  • Has collected 1+ items on Envato Market
two_larsens says

Well, after having changed the permissions as to what the template requires, it still isn’t working (777). This is what it said:

“For correct functionality, please, make sure the following folders have the “777” access settings:

/wp-content/themes/pacifico/images/cache

/wp-content/themes/pacifico/images/social_icons

/wp-content/themes/pacifico/images/theme_icons

/wp-content/themes/pacifico/images/bgs

Still wrong? Or can I set it then to 755?

Thanks again,

HL

3228 posts
  • Has sold $5,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Located in United States
  • Has been part of the Envato Community for over 4 years
+1 more
organicbee says

As I said nothing should ever be set with the permissions 777, if its required to I wouldn’t trust the theme..

If its not working with 777 it most likely wont work with 755, but it’s most likely not a permissions problem then you need to contact the author of the theme for further support

4 posts
  • Has been part of the Envato Community for over 1 year
  • Has collected 1+ items on Envato Market
two_larsens says

Thanks.

It is really frustrating since everything else I think I have, or can get, a handle on.  But when it starts out like that, then it isn't really a good purchasing experience.  The theme Pacifico is from ThemeForest, but it seems like it more a bunch of individual people making these, which makes it helter skelter.  Anyway, sorry for the rant, and thanks again.

HL

by
by
by
by
by
by