185 posts
  • Author had a Free File of the Month
  • Sold between 50 000 and 100 000 dollars
  • Has been a member for 1-2 years
  • Exclusive Author
  • Bought between 1 and 9 items
  • Europe
ikaruna says

Hi folks,

Today i was confronted with a CS6 bug that was really annoying, and that i understand has been awhile around, but no real fix from Adobe came, in form of an update/patch, etc. The bug is that sometimes, from unknown causes, the type tool starts to behave erratically, and when typing, your words’ order is messed up, but only if you have numbers and special characters in your string. This means that if i want to write for ex “19 px padding”, what my type tool really renders is ” padding px 19”. The cursor is placed at the beginning of the string and all numbers and special chars are placed in the beginning. This bugs corrupts the text on that file for good, and if you import some elements into other, new, .psd files, it will corrupt them too. One or two observations though – if you have already some correctly rendered text in that file, and you select some of the text from there ( don’t have to type, just select a few letters or simply click into it), then type a new text, it will keep the ” good formatting ” of that text. And viceversa, if you afterwards click the “bad” text, the next one created will be bad.

So, the solution that worked for me, was this, go to Type > Panels > Paragraph Styles panel. There, in the list, should be a style called Basic Paragraph +, or something similar. Use the dropdown options from the panel’s upper right corner, and choose Delete Style. Then, select one of the “bad” texts, go to Window > Paragraph dropdown menu, and Reset Paragraph. This should do the trick, for me it reverted the problem and saved my files from recreating them from scratch.

I hope this helps someone:)

Cheers,

T.

1 post
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Sold between 1 and 100 dollars
rubypanda says

Thanks for the advice, but I cant erase the basic paragraph, so it does not really work at CC :(

401 posts
  • Author had a Free File of the Month
  • Elite Author
  • Exclusive Author
  • Sold between 100 000 and 250 000 dollars
  • Has been a member for 3-4 years
  • Referred between 200 and 499 users
  • Bought between 100 and 499 items
+2 more
theAlThemist says

As far as I am informed it’s not a CS6 bug. It only happens in one of the pirated/warez versions spread around europe. The reason is because it’s based on the Hebrew version of Photoshop made for Israel market ONLY! The reason is that Hebrew is RTL language.

It can be fixed, but I can’t tell you how as that would be a kind of legitimating piracy here, which I believe is not allowed (and not right) to do.

There are two options -

1. play with the regional/language settings of Photoshop OR search on internet for the right settings

2. Purchase a legal copy of the software.

Just my two cents.

1 post
  • Has been a member for 0-1 years
VrajarV says

Its actually a selection of a wrong setting as listed below” 1/ select text tool 2/select the option of toggle paragraph like a folder on the right of warp text 3/ go in paragraph 4/http://www.photoshopgurus.com/forum/attachments/photoshop-troubleshooting/18914d1339868678-photoshop-text-tool-problem-photoshop-fix.jpg c this image and click either of them ur work will be done Regards VrajarV

185 posts
  • Author had a Free File of the Month
  • Sold between 50 000 and 100 000 dollars
  • Has been a member for 1-2 years
  • Exclusive Author
  • Bought between 1 and 9 items
  • Europe
ikaruna says

As far as I am informed it’s not a CS6 bug. It only happens in one of the pirated/warez versions spread around europe. The reason is because it’s based on the Hebrew version of Photoshop made for Israel market ONLY! The reason is that Hebrew is RTL language.

It can be fixed, but I can’t tell you how as that would be a kind of legitimating piracy here, which I believe is not allowed (and not right) to do.

There are two options -

1. play with the regional/language settings of Photoshop OR search on internet for the right settings

2. Purchase a legal copy of the software.

Just my two cents.

For me it can’t possibly be pirated because this happened on my work pc, and @ work there is a very strict control of the licenses, and we do not even have admin accounts to install our own software – but it did however work exactly as i tried, so i don’t know what to say. Also my version is the classic US one..

3 posts
  • Bought between 1 and 9 items
  • Greece
  • Has been a member for 1-2 years
meymigrou says

To fix this : go to Edit,Preferences?,Type, and change the value to East Asian.

And then restart Photoshop.

Done! :)

by
by
by
by
by
by