158 posts CoralixThemes
  • Elite Author
  • Author Level 8
  • Exclusive Author
  • Copyright Ninja
+5 more
CoralixThemes
says

Hi guys,
I need some help! My last work has a problem with Themeforest top bar. For some reason the demo is working fine but when I try to see the preview (which includes Themeforest top bar some scripts stop working). Any idea?
Themeforest item: http://themeforest.net/item/candidate-political-donation-landing/7143739
Demo here: http://candidate.coralixthemes.com/

1891 posts The Last Man Standing
  • Weekly Top Seller
  • Author Level 8
  • Beta Tester
  • Moderator
+10 more
ImanGM
Moderator
says

Hi,

I guess it’s because some JS codes are not permitted to load when your site is loaded in an iframe from another domain name than your site.

This is why I’ve removed the default ThemeForest top bar on my latest item with one on my own host.

Hope this helps.

Cheers,
Iman

1368 posts
  • Weekly Top Seller
  • 5 Years of Membership
  • Author Level 6
  • Beta Tester
+5 more
Smartik
says
Remove the iframe. Add this in the header of your template.
<script>if ( top !== self ) top.location.replace( self.location.href );</script>
158 posts CoralixThemes
  • Elite Author
  • Author Level 8
  • Exclusive Author
  • Copyright Ninja
+5 more
CoralixThemes
says

Hi, Thank for your help. I try this with my custom top bar but it didn’t work. :(


Hi,

I guess it’s because some JS codes are not permitted to load when your site is loaded in an iframe from another domain name than your site.

This is why I’ve removed the default ThemeForest top bar on my latest item with one on my own host.

Hope this helps.

Cheers,
Iman
158 posts CoralixThemes
  • Elite Author
  • Author Level 8
  • Exclusive Author
  • Copyright Ninja
+5 more
CoralixThemes
says

Thank you so much. It works! You save my day :)


Remove the iframe. Add this in the header of your template.
<script>if ( top !== self ) top.location.replace( self.location.href );</script>
by
by
by
by
by
by