137 posts
  • 5 Years of Membership
  • Author Level 2
  • Collector Level 2
  • Exclusive Author
+1 more
Graphitizer
says

Hello there, I’ve been working on my WordPress Theme Framework and trying to put jQuery UI Slider in my theme option but having problem with ‘jquery.ui.slider.js’ file…

It throws up an error in firebug:
$.ui is undefined

$.widget( "ui.slider", $.ui.mouse, { 

What am I probably missing??? Is it with the jQuery UI mouse widget that is causing error???

610 posts Themes and Graphics
  • 6 Years of Membership
  • Affiliate Level 3
  • Author Level 9
  • Beta Tester
+11 more
Bebel
says

WordPress loads jquery in the noConflict mode. Use jQuery instead of $.

Cheers
Bebel

447 posts Codestar
  • Elite Author
  • Author Level 9
  • Trendsetter
  • Top Monthly Author
+10 more
Codestar
says

Hi,

Strange coincidence, I am working on the framework too. I also had the same problem and solved.
Just tell me, what is the your slider ui version ? is stable 1.8.9 ?

137 posts
  • 5 Years of Membership
  • Author Level 2
  • Collector Level 2
  • Exclusive Author
+1 more
Graphitizer
says

WordPress loads jquery in the noConflict mode. Use jQuery instead of $. Cheers
Bebel

Thanks a lot for your concern but I’ve used jQuery instead of $ but the error $.ui is form the jQuery UI Plugin, I don’t think we can change that :P

I also tried to call my plugin like this but no luck :(
jQuery(document).ready(function($){
....
....
});

Hi, Strange coincidence, I am working on the framework too. I also had the same problem and solved.
Just tell me, what is the your slider ui version ? is stable 1.8.9 ?

Yes, I have the stable 1.8.9 version, any help would be appreciated.

447 posts Codestar
  • Elite Author
  • Author Level 9
  • Trendsetter
  • Top Monthly Author
+10 more
Codestar
says

Hi,

Don’t worries bro. it is easyly. Problem is stable 1.8.9. This version problem on wordpress admin panel, because there is a critical conflict.

Just try to 1.7.3 (Legacy release, for jQuery 1.3.2) version from http://jqueryui.com/download i think you know download versions… When you adapt Legacy release version, you will solve it. ;)

This problem is shitty really! I had a crazy :D LOL

137 posts
  • 5 Years of Membership
  • Author Level 2
  • Collector Level 2
  • Exclusive Author
+1 more
Graphitizer
says

Hi,

Don’t worries bro. it is easyly. Problem is stable 1.8.9. This version problem on wordpress admin panel, because there is a critical conflict.

Just try to 1.7.3 (Legacy release, for jQuery 1.3.2) version from http://jqueryui.com/download i think you know download versions… When you adapt Legacy release version, you will solve it. ;)

This problem is shitty really! I had a crazy :D LOL

Yes, that was crazy! Now it works like a charm… Thanks alot mate!

Will love to see your WordPress Framework and of-course show you mine, in near future!

Regards, Avinash

447 posts Codestar
  • Elite Author
  • Author Level 9
  • Trendsetter
  • Top Monthly Author
+10 more
Codestar
says

You’r welcome :) Good works bro!

Regards, Codestar

by
by
by
by
by
by