6 posts
  • Has been part of the Envato Community for over 1 year
  • Sells items exclusively on Envato Market
rinspeed says

Hello everyone. I initially sent this message to felt_tips but he advised me to post it here so that’s what I’m doing :) If anybody knows the solution, please help.

I’m doing a project to submit here on Videohive but can’t render a decent preview in FLV format, it always comes out pixelated. I’ve been trying to fix this for the past 3 days but nothing seems to work. I’ve tried all the solutions I could think of: tons of different settings, used Media Encoder, even tried Sorenson Squeeze. But still when encoding is finished a get a pixelated output. It especially pixelates when there’s a rapid movement in the scene. I know that fast animation plays a role in what settings you choose to encode, but as I said I tried lots of different settings.

Overall, I have 18 second animation with particles from Particular plugin, there are a few abrupt movements of particles but nothing too extreme. I see a lot of previews here that look crystal clear (e.g. Dual Reality project) and I’m just dying to know what am I doing wrong.

Here’s the process I went through:

1. I did my project using 60 fps comps (that’s because when I was doing particle animation I had some problems with smoothness and switching to 60 fps helped me). I checked the “Preserve frame rate when nested” checkbox for all my comps. For the final ‘render comp’ I switched to 25 fps.

2. Initially I rendered my main comp as a TIFF sequence at 1080p. I then made some changes to the project and replaced some of the frames in the sequence.

3. Then I rendered the TIFF sequence into Quicktime Animation format at 960×540. (I had 3 sequences actually, to display different versions of the project). Up to this point everything looks cool. I pulled those renders in Premiere Pro and put together a final preview (added some text etc.).

4. At this point I tried to export my preview video from Premiere via Media Encoder into FLV format. When encoding is done I get a pixelated video. I tried different bitrates(1000-5000kbps), key frame distances etc.

Formats like MP4 look just fine. I don’t know what’s wrong with FLV. I use CS6 by the way.

I rendered my preview about 30 times already and was able to get only one version where it doesn’t look pixelated all the time, but it’s still bad.

5179 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Helps us moderate the forums
  • Provided great contribution to our forums
+12 more
felt_tips Moderator says

Hello everyone. I initially sent this message to felt_tips but he advised me to post it here so that’s what I’m doing :) If anybody knows the solution, please help.
Here I am! :-)

1. I did my project using 60 fps comps (that’s because when I was doing particle animation I had some problems with smoothness and switching to 60 fps helped me). I checked the “Preserve frame rate when nested” checkbox for all my comps. For the final ‘render comp’ I switched to 25 fps.

That’s actually not a very good solution to the problem you’re experiencing. Since 60fps is not divisible by 25fps, it may cause you to have cadence problems. It’s a bit like importing a piece of 60fps footage into a 25 fps project. If you are having problems with smoothness, you could look at your motion blur settings. Alternatively, you can turn motion blur off for that pre-comp and apply a CC Force Motion Blur effect (older versions of Trapcode use a linear interpolation between points which is a bit ugly sometimes). But if your project is for instance 25fps, with a 180 degree shutter angle and no shutter phase offset, then you should generally leave this setting right throughout the structure for best results… or at least until you have an intuitive understanding of what these things do.


2. Initially I rendered my main comp as a TIFF sequence at 1080p. I then made some changes to the project and replaced some of the frames in the sequence.

Makes sense!


3. Then I rendered the TIFF sequence into Quicktime Animation format at 960×540. (I had 3 sequences actually, to display different versions of the project). Up to this point everything looks cool. I pulled those renders in Premiere Pro and put together a final preview (added some text etc.).
Also fine, although apart from the real-time playback issue, there’s no reason why you shouldn’t add text etc. in After Effects. If you’re having problems, it usually helps to narrow down the cause of the problem if you don’t use other software unnecessarily.

4. At this point I tried to export my preview video from Premiere via Media Encoder into FLV format. When encoding is done I get a pixelated video. I tried different bitrates(1000-5000kbps), key frame distances etc. Formats like MP4 look just fine. I don’t know what’s wrong with FLV. I use CS6 by the way.

It might not be to do with the codec so much as to do with Premiere or Media Encoder’s implementation of the codec.

Generally, I have exported FLV directly out of After Effects, and it generally comes out fine. I’m not a big fan of FLV to be honest, but Ae usually does the trick. One thing not to be caught out by when you’re starting out is the perceptual effect. You have the benefit(?) of having seen your own project at super high uncompressed resolution, so when you compress it, you’ll notice every tiny flaw. The other projects that you look at on Videohive, you probably look at with a much less critical eye, because you have never seen the original version.


I rendered my preview about 30 times already and was able to get only one version where it doesn’t look pixelated all the time, but it’s still bad.

Nothing wrong with that. There’s quite an art to compression and it takes a long time to learn. I’ve been compressing things into a variety of different formats for nearly two decades. If you think it’s hard now, you should have been there with Cinepak in 1995! :-)

Have a look at this old thread too. There was some similar stuff being asked there, although it was more to do with h.264 than FLV

http://videohive.net/forums/thread/rendering-motion-graphics/82180?page=1

Oh… and I’m sure some of the guys and girls will be able to chip in here and let you know exactly what settings they’re using to export from After Effects. In my case, it’s so long since I’ve uploaded a file, that I’ve lost my normal settings.

6 posts
  • Has been part of the Envato Community for over 1 year
  • Sells items exclusively on Envato Market
rinspeed says

Thanks so much for your reply!

That’s actually not a very good solution to the problem you’re experiencing. Since 60fps is not divisible by 25fps, it may cause you to have cadence problems. It’s a bit like importing a piece of 60fps footage into a 25 fps project.

I think this may be my problem. I just decided to rebuild my project a little to make it look better, so I will also convert everything to normal fps.

It might not be to do with the codec so much as to do with Premiere or Media Encoder’s implementation of the codec.

In my case it’s either the codec or the project. I tried rendering out from everything: AE, Premiere, Media Encoder, Squeeze. And it all looks the same.

Generally, I have exported FLV directly out of After Effects, and it generally comes out fine. I’m not a big fan of FLV to be honest, but Ae usually does the trick.

I also thought it should be fine. I contacted one of the authors here and asked him how he achieves good quality and basically his reply was: “nothing fancy, just rendering out from AE CS4”. He did mention that sometimes he gets terrible results too.

One thing not to be caught out by when you’re starting out is the perceptual effect. You have the benefit(?) of having seen your own project at super high uncompressed resolution, so when you compress it, you’ll notice every tiny flaw. The other projects that you look at on Videohive, you probably look at with a much less critical eye, because you have never seen the original version.

I actually thought about it :) I’ll try to be more open minded to my compressed files. But still I think in this case it was a really big flaw :)

Nothing wrong with that. There’s quite an art to compression and it takes a long time to learn. I’ve been compressing things into a variety of different formats for nearly two decades. If you think it’s hard now, you should have been there with Cinepak in 1995!

Well, I will practice!

Have a look at this old thread too. There was some similar stuff being asked there, although it was more to do with h.264 than FLV

Thanks. Reading through this thread now, many useful tips there.

Oh… and I’m sure some of the guys and girls will be able to chip in here and let you know exactly what settings they’re using to export from After Effects.

That would be nice :)

Really appreciate your help!

427 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Contributed a free file of the month
+3 more
Panda-Bear says

.

427 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Contributed a free file of the month
+3 more
Panda-Bear says

Can i ask what version of AE you’re using? i had the same problem in CS5.5, whereby it really didn’t like to render .flv :(

Upon upgrading to CS6, still odd problems would occur. It’s a bit hit and miss.

My particular solution is now always to make my .FLVs in Adobe Premier. Just put the originally rendered AE footage on one Adobe Premier Layer, then put the ghost VH watermark on another layer. – Renders flvs with no problem at all and can be as high a quality as you want (i sometimes use 960×540 for flv previews. It makes sense because creating a preview using a linear editing system is similar to creating a movie trailer – you can cut/edit your flv file much more simply.

I find this way much simpler, quicker, and it has the added benefit of ease to add audio/sound fx to the flv as well.

342 posts
  • Has referred 1+ members
  • Has sold $1,000+ on Envato Market
  • Has collected 100+ items on Envato Market
  • Located in United Kingdom
+2 more
StencilMedia says

Have you tried constant bitrate at 10,000kbps? I think the default for FLV output in CS6 is variable bitrate.

5179 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Helps us moderate the forums
  • Provided great contribution to our forums
+12 more
felt_tips Moderator says

Variable bit-rate should give much better results for any given bit-rate. The trade-off is that it takes longer to analyze and compress.

342 posts
  • Has referred 1+ members
  • Has sold $1,000+ on Envato Market
  • Has collected 100+ items on Envato Market
  • Located in United Kingdom
+2 more
StencilMedia says

I thought a constant bitrate helped with pixelation in dark areas and grain and the like? I could be wrong though, might just be an old wives tale.

6 posts
  • Has been part of the Envato Community for over 1 year
  • Sells items exclusively on Envato Market
rinspeed says
Can i ask what version of AE you’re using? i had the same problem in CS5.5, whereby it really didn’t like to render .flv

CS6.

I also found this thread on Adobe forums where people talk about an issue with FLV format in CS6, particularly with rendering with 2-pass VBR: http://forums.adobe.com/message/4818707

6 posts
  • Has been part of the Envato Community for over 1 year
  • Sells items exclusively on Envato Market
rinspeed says

It turns out there is a simple way to produce a good quality preview. I just got Quicktime Pro and found that its h.264 exporter is amazing. When exporting my video, I just type in ”.flv” as a file extension, and that way it exports a great quality FLV file. And I can adjust the compression quality in the settings to make file size smaller, but the video quality stays decent.

My question is: is it OK to upload this FLV preview with my project? Apparently the only difference is that it’s encoded with h.264, not On2 VP6.

by
by
by
by
by
by