4335 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Community Moderator
  • Contributed a Blog Post
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
+6 more
Reaper-Media Volunteer moderator says

Long story short… Messed up my boot sequence completely… :(

Long version.

I had vista and windows 7 installed on my computer, windows 7 was installed after vista and so when I installed it, it ADDED to the boot loader that resided on the harddrive with windows vista on it and didn’t add a single boot sequence to the drive it was being installed on. This morning, I go and install ubuntu on the windows vista drive unaware that the entire windows boot sequence resided on it. Now after about 10 hours of trying to get it to work, I have made virtually no progress. I can’t even get GRUB to work with it… Sigh… And what’s more, when windows 7 was installed, it didn’t even mark the partition it was on as bootable, and I have no idea of how to reconstruct the boot sequence on the win7 drive.

I’ve already tried the startup recovery from the install disc to no avail… Any suggestions guys? :)

3007 posts
  • Exclusive Author
  • Beta Tester
  • Envato Studio (Microlancer) Beta Tester
  • Sold between 1 and 100 dollars
  • Has been a member for 4-5 years
  • Bought between 50 and 99 items
  • United States
TNL3542 says

hmmm thats werid you should beable to do a complete system restall.. from scratch like brand new i have vista on my computer.. and i whipe out my system every so offten

413 posts
  • Bought between 50 and 99 items
  • Exclusive Author
  • Has been a member for 5-6 years
  • Referred between 100 and 199 users
  • United Kingdom
  • Won a Competition
altinkum says

needs expert to recover but do you never back up ? just trying to get my MCDST and uni next

296 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 1 000 and 5 000 dollars
  • Bought between 1 and 9 items
  • Referred between 1 and 9 users
  • United Kingdom
theninja says

So your MBR no longer exists… okay. I think this can be fixed although I’m not entirely sure.
I had a look around and found a possible fix on a forum… you can try it and see if it works :)
Here’s the compact version :
Insert the windows 7 installation disc, once you’ve accessed the system recovery options dialog click “Command Prompt”.
Type Bootrec /Rebuildbcd , and then press ENTER . If the Bootrec.exe tool runs successfully, it presents you with an installation path of a Windows directory. To add the entry to the BCD store, type Yes. A confirmation message appears that indicates the entry was added successfully.
If the Bootrec.exe tool cannot locate any missing Windows installations, you must remove the BCD store, and then you must re-create it.
To do this, type the following commands in the order in which they are presented. Press ENTER after each command.
Bcdedit /export C:\BCD_Backup
ren c:\boot\bcd bcd.old
Bootrec /rebuildbcd

Restart the computer.

296 posts
  • Exclusive Author
  • Has been a member for 5-6 years
  • Sold between 1 000 and 5 000 dollars
  • Bought between 1 and 9 items
  • Referred between 1 and 9 users
  • United Kingdom
theninja says

This might help more http://support.microsoft.com/kb/927392
(it could be that one of the other options like /FixBoot is more what you’re after)

499 posts
  • Canada
  • Exclusive Author
  • Sold between 1 000 and 5 000 dollars
  • Has been a member for 5-6 years
  • Bought between 10 and 49 items
  • Referred between 1 and 9 users
TutelageSystems says

Sorry to hear that, bummer.

I hope you get everything back soon

4335 posts
  • Beta Tester
  • Bought between 10 and 49 items
  • Community Moderator
  • Contributed a Blog Post
  • Contributed a Tutorial to a Tuts+ Site
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
+6 more
Reaper-Media Volunteer moderator says

@TNL: I could reinstall if I want to, but I really don’t want to have to go through all the hassle of reinstalling everything…

@altinkum: yep all my dsta is backed up, this is my OS drive.

@theninja: yeah I’ve already tried using bootrec but still with no results… Thanks for the help though.

Ideas are still welcome :)

3007 posts
  • Exclusive Author
  • Beta Tester
  • Envato Studio (Microlancer) Beta Tester
  • Sold between 1 and 100 dollars
  • Has been a member for 4-5 years
  • Bought between 50 and 99 items
  • United States
TNL3542 says

ok just trying to be helpfull good luck

3085 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 4-5 years
  • Interviewed on the Envato Notes blog
  • Referred between 10 and 49 users
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+1 more
Raincutter says

ummm… maybe you can give a minute and read this. I’m no hardware or system expert and just thought this thread had a little resemblance to your problem. So shared it with you. I think the second reply below question from the thread might help you.

http://superuser.com/questions/25728/how-to-fix-windows-7-boot-process

30 posts
  • Bought between 100 and 499 items
  • Has been a member for 6-7 years
  • United States
petterro says

Don t install anything !!! Just get a Mac !!! :) No offense man !!! I know what you mean cause I was in something like that few years back… I learned my lesson the hard way like you do today… Cheers !!!

by
by
by
by
by
by