24 posts
  • Bought between 1 and 9 items
  • Has been a member for 5-6 years
CreativeBoy says

I got a problem in PHP . I have 2 documents: test.php and index2.php . In test.php it gets data from MySQL db. Data is in Russian. Test.php shows correctly it. But, when i include it to index2.php it shows incorrect. In test.php there is nothing, just it get’s from mysql. There is no doctype, content-type and etc. But in index2.php there are all. My charset is UTF -8 which shows Russian normally in other places.

Here are both of them: test.php

index2.php

Thanks a lot…

352 posts
  • Author had a File in an Envato Bundle
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
  • Exclusive Author
  • Has been a member for 6-7 years
  • Referred between 50 and 99 users
  • Sold between 10 000 and 50 000 dollars
+1 more
danharper says

Erm, it’s hard to see where the problem is. What exactly isn’t working for you?

For me, test.php is outputting:
???????

And index2.php:
some other russian here. forum wont display it then: ???????

BTW , why is your test.php (which you say is only getting the info from the DB) outputting data at all?

Perhaps you could zip your PHP files so that we can actually see the code.

24 posts
  • Bought between 1 and 9 items
  • Has been a member for 5-6 years
CreativeBoy says

OMG ! what is it :((((

I did nothing. But it changed to normal automatically. Really… It was showing ?? before… Now it’s working… Anyways thanks…

by
by
by
by
by
by