7 posts
  • Has been part of the Envato Community for over 4 years
  • Has collected 100+ items on Envato Market
pleiadene says

I sincerely think that products that the author does not keep up to date with the official WordPress version should be disabled/prevented from being sold until the author fixes current version compatibility, only then should the plugin be enabled for sale again.

I am tired of browsing outdated plugins that does not work with WordPress 3.6, and there is no reason to use anything below this version, mostly due to security reasons. Why on earth would I want to run a WordPress 3.5 install?

Also, a lot of author’s simply do not reply to comments, or the plugin drifts in space and even trying to reach the author by sending a message through their profile is to no avail…

For older (not brand new plugins) I have to start almost every comment with “does it have wordpress 3.6 compability?”

Same with Wordpress themes, a certain author has vanished… no replies to either comments or profile message… I want to buy his theme, but worried that the theme is not Wordpress 3.6 compatible…

and Envato….

PLEASE GIVE ME A COMMENT HISTORY LOG… sometimes I make a comment, forget to click email me when someone posts a reply, and forget all about it.

911 posts Never trust a ballerina with a moustache
  • Has been part of the Envato Community for over 3 years
  • Located in Australia
  • Interviewed on an Envato blog
  • Has collected 10+ items on Envato Market
+6 more
Carmen says

Hi pleiadene,

Thank you for taking the time to give us feedback. I appreciate your insights about older plugins.

  • In relation to authors not responding to comments, support is currently not mandatory. We suggest that before purchasing you check the item comments and ensure that the author is active and does provide basic support.
  • The compatibility options for the item should be listed on the item page in the right hand column.
  • It’s great to know that you would consider a comment history log useful, I’ll share this with our UX team.

Thanks again pleiadene, I’ll be forwarding all your feedback and suggestions to the team. :)

5360 posts The Dude Abides
  • Located in United States
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Has been part of the Envato Community for over 5 years
+9 more
CodingJack says

Maybe before a new WP version is released, a blanket email can go out to all WP authors reminding them to update their items and subsequently update their item’s “compatible with” list. Then a few weeks later, for any items where the latest version isn’t officially selected, the buyer is presented with a “this item may not be compatible with the latest version of WordPress” message.

7 posts
  • Has been part of the Envato Community for over 4 years
  • Has collected 100+ items on Envato Market
pleiadene says

I know support is not mandatory but when the support question I want an answer to is:

is your plugin/theme compatible with wordpress v3.6? and that is the only thing from keeping you back from buying the plugin or theme… it’s frustrating having to browse outdated plugins that either break your site or don’t work with the latest version, because running anything less than the latest version is a security risk and on top paying for the privileged.

and there is no reply for weeks or even months as in some cases…

there are several themes out there I want to buy, but since the author does not reply in any way shape or form, to either comments or direct private message via their profile, I simply cannot risk wasting time and money to find out if it is compatible or not.

same with plugins, outdated or incompatible plugins…. a waste of browsing space, time and money.

911 posts Never trust a ballerina with a moustache
  • Has been part of the Envato Community for over 3 years
  • Located in Australia
  • Interviewed on an Envato blog
  • Has collected 10+ items on Envato Market
+6 more
Carmen says

Hi pleiandene,

Thanks again for taking the time to give your feedback. We do aim to keep the library up to date within a certain number of recent versions. Our authors create a huge range of items, which don’t always require the latest version. This is due to a variety of reasons. We suggest than you make sure to search for items with the compatibility you need. The version compatibility of an item is listed in the item’s attributes column. I hope this helps! :)

by
by
by
by
by
by