449 posts
  • Has referred 100+ members
  • Has sold $10,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Had an item featured on Envato Market
+4 more
Final_Step says

Hello Everyone, I was trying to open a support ticket and wasn’t able to do so because there is a problem of the ticket’s page:

Maybe some of you have the same problem. Can anybody help? Staff?

1573 posts AEdorde.com - After Effects Projects
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Has referred 1000+ members
  • Has been part of the Envato Community for over 5 years
+9 more
dorde says

Very strange. :/ Looks fine here. Try ctrl+F5, or in other browser.

241 posts
  • Has referred 1+ members
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+5 more
rendertom says

Looks good on my end. Maybe you submit too many tickets, so Envato started playing tricks on you :)

5220 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $125,000+ on Envato Market
  • Helps us moderate the forums
  • Has been part of the Envato Community for over 5 years
+11 more
felt_tips Moderator says

It looks to me a little bit like a font resource has gone awol on your computer. Mind you, I’m not sure how web pages work these days… whether they access the fonts on your system or if they’re somehow built into the page. It’s a long time since I did any web stuff.

410 posts
  • Has referred 100+ members
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Made it to the Authors' Hall of Fame
+3 more
GhosTeam says

If you’re working with Chrome, try in the Chrome-Menu:
Tools – Encoding – and check “Auto-Detect”, Or try checking “Unicode (UTF-8)” if it’s not already checked.

1001 posts
  • Has referred 1+ members
  • Has sold $10,000+ on Envato Market
  • Has collected 100+ items on Envato Market
  • Member of the Envato Team
+7 more
baf2681 Envato team says

Common google chrome issue when using a font manager app. have it happening on other sites myself.

123 posts
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
+1 more
WilQ5 says

I have checked support too so Actually for me support isin’t working at all…. i see normal simbols but if you want to open the ticket there is an error message : Invalid department ID specified; please select a valid department. and there is no difference wich one department you will click, it will be the same message :) so maybe they are doing some background changes ? :)

340 posts
  • Has referred 1+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
+2 more
MotionMAX says

yes iam getting the same problem I am trying to change my username it does not work showing the same error message that wilq5 explained

5779 posts
  • Member of the Envato Team
  • Has been part of the Envato Community for over 4 years
  • Located in Canada
  • Joined us in one of our Envato Live Events
+13 more
KingDog Envato team says

If you get the Invalid Department ID try emptying your browser cache and restarting the browser. I’ve been hearing that has worked for some. Thanks!

449 posts
  • Has referred 100+ members
  • Has sold $10,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Had an item featured on Envato Market
+4 more
Final_Step says

If you get the Invalid Department ID try emptying your browser cache and restarting the browser. I’ve been hearing that has worked for some. Thanks!

Sorry but it doesn’t work.

by
by
by
by
by
by