449 posts
  • Affiliate Level 4
  • Author Level 5
  • Collector Level 2
  • Featured Item
+4 more
Final_Step
says

Hello Everyone, I was trying to open a support ticket and wasn’t able to do so because there is a problem of the ticket’s page:

Maybe some of you have the same problem. Can anybody help? Staff?

1636 posts AEdorde.com - After Effects Projects
  • Elite Author
  • Helpful Hacker
  • Author Level 8
  • Affiliate Level 7
+11 more
dorde
says

Very strange. :/ Looks fine here. Try ctrl+F5, or in other browser.

243 posts
  • Affiliate Level 2
  • Author Level 4
  • Collector Level 1
  • Weekly Top Seller
+6 more
rendertom
says

Looks good on my end. Maybe you submit too many tickets, so Envato started playing tricks on you :)

5327 posts
  • Elite Author
  • Moderator
  • Weekly Top Seller
  • Top Monthly Author
+13 more
felt_tips
Moderator
says

It looks to me a little bit like a font resource has gone awol on your computer. Mind you, I’m not sure how web pages work these days… whether they access the fonts on your system or if they’re somehow built into the page. It’s a long time since I did any web stuff.

415 posts
  • Weekly Top Seller
  • Author Level 6
  • Featured Author
  • 4 Years of Membership
+3 more
GhosTeam
says

If you’re working with Chrome, try in the Chrome-Menu:
Tools – Encoding – and check “Auto-Detect”, Or try checking “Unicode (UTF-8)” if it’s not already checked.

1002 posts
  • Copyright Ninja
  • Top Monthly Author
  • Weekly Top Seller
  • Envato Team
+10 more
BF_Motion
Envato team
says

Common google chrome issue when using a font manager app. have it happening on other sites myself.

131 posts
  • Author Level 5
  • Beta Tester
  • Collector Level 1
  • Weekly Top Seller
+2 more
WilQ5
says

I have checked support too so Actually for me support isin’t working at all…. i see normal simbols but if you want to open the ticket there is an error message : Invalid department ID specified; please select a valid department. and there is no difference wich one department you will click, it will be the same message :) so maybe they are doing some background changes ? :)

551 posts
  • Trendsetter
  • Weekly Top Seller
  • Exclusive Author
  • Author Level 5
+4 more
MotionMAX
says

yes iam getting the same problem I am trying to change my username it does not work showing the same error message that wilq5 explained

6839 posts
  • Envato Team
  • 5 Years of Membership
  • Canada
  • Envato Live Participant
+13 more
KingDog
Envato team
says

If you get the Invalid Department ID try emptying your browser cache and restarting the browser. I’ve been hearing that has worked for some. Thanks!

449 posts
  • Affiliate Level 4
  • Author Level 5
  • Collector Level 2
  • Featured Item
+4 more
Final_Step
says

If you get the Invalid Department ID try emptying your browser cache and restarting the browser. I’ve been hearing that has worked for some. Thanks!

Sorry but it doesn’t work.

by
by
by
by
by
by