195 posts
  • Has been part of the Envato Community for over 5 years
  • Has collected 500+ items on Envato Market
  • Located in United States
ace2296 says

Your site loads in an acceptable time range (around 2-3 seconds for me).
Honestly, i think your server speed is what is causing the delay, not your contents.

thanks your the feedback I’ll take a look into it.

195 posts
  • Has been part of the Envato Community for over 5 years
  • Has collected 500+ items on Envato Market
  • Located in United States
ace2296 says


^ Around two sec again. That is quite acceptable. By the way those drops flying around are quite annoying form me. :) What they represent?
I actually like the drops, it was implemented in order to create the bubble effect in water I guess. In comparison with the website shown by you, yours loads slower which will damage your client’s experience.

Thanks for the feedback. We’re working to speed things up.

3466 posts
  • Elite Author: Sold more than $75,000 on Envato Market
  • Has sold $750,000+ on Envato Market
  • Located in United States
  • Helps us moderate the forums
+10 more
sevenspark Moderator says

Have you used YSlow to help analyze your load times?

(You’re loading 30 external scripts, for example – if you use a minifier and combine them into one, you’ll save a lot of HTTP requests).

815 posts
  • Has referred 1+ members
  • Has sold $10,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Contributed a free file of the month
+3 more
rvision_ says

Try to start the animations when background images are done loading.

+1 for sevenspark’s advice

by
by
by
by
by
by