192 posts
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • United States
ace2296 says

Your site loads in an acceptable time range (around 2-3 seconds for me).
Honestly, i think your server speed is what is causing the delay, not your contents.

thanks your the feedback I’ll take a look into it.

192 posts
  • Bought between 100 and 499 items
  • Has been a member for 5-6 years
  • United States
ace2296 says


^ Around two sec again. That is quite acceptable. By the way those drops flying around are quite annoying form me. :) What they represent?
I actually like the drops, it was implemented in order to create the bubble effect in water I guess. In comparison with the website shown by you, yours loads slower which will damage your client’s experience.

Thanks for the feedback. We’re working to speed things up.

3422 posts
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Community Moderator
  • Bought between 100 and 499 items
  • Referred more than 2000 users
  • Has been a member for 4-5 years
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+4 more
sevenspark Volunteer moderator says

Have you used YSlow to help analyze your load times?

(You’re loading 30 external scripts, for example – if you use a minifier and combine them into one, you’ll save a lot of HTTP requests).

814 posts
  • Author had a Free File of the Month
  • Exclusive Author
  • Sold between 10 000 and 50 000 dollars
  • Bought between 1 and 9 items
  • Referred between 1 and 9 users
  • Serbia
  • Has been a member for 5-6 years
rvision_ says

Try to start the animations when background images are done loading.

+1 for sevenspark’s advice

by
by
by
by
by
by