3007 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
+2 more
duotive says

i have a problem with a website on united hosting. when calling timthumb.php it gives a 500 internal server error. any ideas what can i do?

397 posts
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
  • Sold between 10 000 and 50 000 dollars
Monkify says

Most likely it’s a hosting issue, I had multiple clients who had the same.

I usually told them to report the problem to the hosting company explaining it’s something in their configuration, and they fixed it 99% of the time.

3007 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
+2 more
duotive says
Most likely it’s a hosting issue, I had multiple clients who had the same. I usually told them to report the problem to the hosting company explaining it’s something in their configuration, and they fixed it 99% of the time.

This hosing has an issue. It dose not know what do to.

3007 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
+2 more
duotive says

any ideas what changes need to be made on the server?

397 posts
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 10 and 49 users
  • Sold between 10 000 and 50 000 dollars
Monkify says

TimThumb uses the PHP -GD extension. If it’s not installed (as always happens with me) your thumbnails will silently fail to be generated.

Debian: ‘apt-get install php5-gd‘ CentOS/RedHat/Fedora TIP : ‘yum install php-gd‘

By default TimThumb reads and writes to the /cache and /temp sub-folders under the directory the PHP script is currently contained in. Your web server will need full read/write access to those two subdirectories.

And that should do it — if you are running into more complicated issues like the PHP script failing to even execute you might have a setup problem.

3007 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
+2 more
duotive says
TimThumb uses the PHP -GD extension. If it’s not installed (as always happens with me) your thumbnails will silently fail to be generated.

Debian: ‘apt-get install php5-gd‘ CentOS/RedHat/Fedora TIP : ‘yum install php-gd‘

By default TimThumb reads and writes to the /cache and /temp sub-folders under the directory the PHP script is currently contained in. Your web server will need full read/write access to those two subdirectories.

And that should do it — if you are running into more complicated issues like the PHP script failing to even execute you might have a setup problem.

Thank you. I will forward this to the hosting support team.

20 posts
  • Author had a File in an Envato Bundle
  • Author had a Free File of the Month
  • Bought between 50 and 99 items
  • Elite Author
  • Exclusive Author
  • Has been a member for 4-5 years
+2 more
olegnax says

It looks like security restriction to execute scripts from subfolders.

When running your scripts, if you receive a 500 Internal Server Error message, please check the following:

1. Check to make sure the file permission is set to 700 (read, write, and execute for owner only).

2. Check the Directory (folder) permission. Setting it to 777 will give you a 500 – Internal Server Error. Set it to 711.

I hope it’s help you.

3007 posts
  • Author had a File in an Envato Bundle
  • Bought between 1 and 9 items
  • Elite Author
  • Europe
  • Exclusive Author
  • Has been a member for 4-5 years
  • Referred between 100 and 199 users
+2 more
duotive says
It looks like security restriction to execute scripts from subfolders.

When running your scripts, if you receive a 500 Internal Server Error message, please check the following:

1. Check to make sure the file permission is set to 700 (read, write, and execute for owner only).

2. Check the Directory (folder) permission. Setting it to 777 will give you a 500 – Internal Server Error. Set it to 711.

I hope it’s help you.

Thank you very much for the information.

3 posts
  • Bought between 100 and 499 items
  • Has been a member for 4-5 years
xwintermute says

Here is a TimThumb troubleshooting guide I’ve seen several authors use in their docs. Hope this helps!

TimThumb isn’t working on your server? Try all of these:

The image must be hosted on your domain. This is for security reasons. The file Arrowhead/php/timthumb.php should have 644 permissions. The folder Ar- rowhead/php/cache should have 777 permissions. If this doesn’t work, try giving 755 permissions to cache. See here on how to give files and folders permissions (called CHMODing).

Make sure your server has the GD library for PHP enabled. Ask your hosting provider, if you don’t know what this means.

Make sure that you don’t add www if your site doesn’t use it. Go to http://www.yourdo- main.com . If you are redirected to http://yourdomain.com , then don’t add www. The reverse also applies.

If absolute image paths (http://domain.com/uploads/image.jpg) don’t work, try using relative paths (/uploads/image.jpg)

If you try to resize a massive image (a few MB in size, for example), you will run into problems. try reducing the quality of the image.

If you are hosted with HostGator or if you are not sure what’s wrong, ask your hosts; often, the mod_security settings play havoc with TimThumb. Your hosts will have to al- low usage of TimThumb.

Recently, I ran across a problem where the user was downloading bitmap(.bmp) im- ages and just changing the extension to .jpg. While this may seem like a great idea, a computer isn’t so easily fooled. You must change the extension correctly (eg by open- ing the image in Photoshop and saving it as JPG ).

415 posts
  • Elite Author
  • Sold between 250 000 and 1 000 000 dollars
  • Has been a member for 5-6 years
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Bought between 10 and 49 items
  • Referred between 10 and 49 users
  • Portugal
unisphere says

I’ve got TimThumb included in one of my older themes and the most common error with it is users giving bad permissions to folder. Make sure that all folder and sub-folders of /wp-content/ included have the 755 permissions. The same for files but this time 644. Also set 777 permissions to the /cache/ folder. This solves 99% of my buyers questions about TimThumb.

Best regards, hope this helps

by
by
by
by
by
by