2 posts
  • Has been part of the Envato Community for over 2 years
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
curvepixell says

My last opencart theme http://themeforest.net/item/anycart-elegant-and-responsive-opencart-theme/3005425?sso?WT.ac=category_item&WT.seg_1=category_item&WT.z_author=stevemun7 Anycart is running fine on demo link. But three buyers comment that after install this theme it shows issue on there live url.

Issue mention below.

Notice: Error: Table ‘opencart.product_tag’ doesn’t exist Error No: 1146 SELECT * FROM product_tag WHERE product_id = ‘50’ AND language_id = ‘1’ in /public_html/newsite/system/database/mysql.php on line 49


Theme supported opencart version 1.5.4.1 the latest one also running on my demo.

For last three negative comments my theme is not selling good. Please suggest me or give some solution if some one knows. I will be great full always.

7 posts
  • Has collected 10+ items on Envato Market
  • Has been part of the Envato Community for over 2 years
  • Located in United States
  • Sells items exclusively on Envato Market
inradius says

I don’t know anything about opencart or its database table structure, but there is a php code requesting a mysql query that just doesn’t exist in the database according to that error. I looked on google, and that table, product_tags is a table from an old version of the software that is no longer used. http://forum.opencart.com/viewtopic.php?t=82463

I would direct your theme buyers to that link and inform them that they need to fully upgrade their opencart software for the error to go away. To be safe, they should obviously run a database backup beforehand. Just incase anything goes terribly wrong with that update script.

Hope that helps in some way.

2 posts
  • Has been part of the Envato Community for over 2 years
  • Has sold $5,000+ on Envato Market
  • Has collected 1+ items on Envato Market
  • Sells items exclusively on Envato Market
curvepixell says

Issue is resolved, Need to change little bit code in product.php (catalog >> controller >> product >> product.php). Actually that issue because of opencart 1.5.3.1 product table update on opencart version 1.5.4.1. :)

Thank You.

1 post
  • Has been part of the Envato Community for over 5 years
  • Has collected 100+ items on Envato Market
  • Located in United States
nkhouli says

Issue is resolved, Need to change little bit code in product.php (catalog >> controller >> product >> product.php). Actually that issue because of opencart 1.5.3.1 product table update on opencart version 1.5.4.1. :) Thank You.

Can you please elaborate on what you did to fix the problem?

Thanks

by
by
by
by
by
by